Downloading file fails to pass name to "Save" dialog

VERIFIED DUPLICATE of bug 16043

Status

()

Core
Networking
P3
critical
VERIFIED DUPLICATE of bug 16043
19 years ago
3 months ago

People

(Reporter: ckritzer (gone), Assigned: Gagan)

Tracking

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Overview Description: When downloading a file which causes the Unknown File Type
dialog to come up, clicking on 'Save File' does not pass the file name to the
Save File dialog box.

Steps to Reproduce:
1) Launch 1999120109 Linux or 1999120108 MacOS builds (this works file on Win32
builds)
2) Load
ftp://sweetlou/products/client/seamonkey/32bit/x86/1999-12-01-13-M12/xpi/aim.xpi
into the Location field and hit enter
3) An Unknown File Type dialog should appear.  Click on the Save File... text.
4) A Save File dialog should appear.

Actual Results:
	On MacOS86 - 'untitled' appears in the Name: field
	On Linux6 - the file name field is blank
	(On Win98 - the file name [aim.xpi] appears correctly in the File name: field)

Expected Results: The file name [aim.xpi] to appear correctly in the file name
field

Build Date & Platform Bug Found:
	Linux6 1999120109 mozilla
	MacOS86 1999120108 mozilla

Additional Builds and Platforms Tested On:
	Win98 1999120113 mozilla - behaves correctly

Additional Information: found this while regressing bug#18725

Comment 1

19 years ago
Mass move of all bugs without target milestones to M13.

Comment 2

19 years ago
the defaultname is not used in nsFileWidget :: PutFile (file: mozilla/ widget/
src/ mac/ nsFileWidget.cpp)

Comment 3

19 years ago
Bulk move of all Networking-Core (to be deleted component) bugs to new
Networking component.
(Reporter)

Updated

19 years ago
QA Contact: tever → ckritzer
(Reporter)

Comment 4

19 years ago
Re-setting self to qacontact & cc'ing tever...

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 5

19 years ago
>>> swat! <<<

*** This bug has been marked as a duplicate of 16043 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Read both bug reports and this appears to be the smae bug.  Verifing as a
duplicate.

Comment 7

3 months ago
Pushed by ecoal95@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/5b6a0fb898ae
No bug - Update test expectations to account for servo/servo#20583. r=me
You need to log in before you can comment on or make changes to this bug.