Closed Bug 205837 Opened 21 years ago Closed 20 years ago

OS/2 Installer leaves behind junk in the temporary directory

Categories

(SeaMonkey :: Installer, defect)

x86
OS/2
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: enigma2, Assigned: mkaply)

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.4b) Gecko/20030509
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.4b) Gecko/20030509

OS/2 Installer leaves behind junk in the temporary directory
ex:
[C:\tcpip\tmp]dir ns_temp\mozilla

The volume label in drive C is OS2.
The Volume Serial Number is 686D:9415.
Directory of C:\tcpip\tmp\ns_temp\mozilla

 5-12-03   5:42p     <DIR>           0  .
 5-12-03   6:03p     <DIR>           0  ..
        2 file(s)          0 bytes used
                   300499968 bytes free

[C:\tcpip\tmp]


Reproducible: Always

Steps to Reproduce:
1.install mozilla
2.look in temp directory
3.see junk

Actual Results:  
installer leftovers

Expected Results:  
no installer leftovers
It´s the same with win98. Each installation leaves a folder named ns_temp with
an appended nbr on it, contents 10 files, three folders, about 1.3 MB.
Now I´ve got ns_temp2 and ns_temp3, next installation will produce ns_temp4.
Installed from win32-installer-sea.exe.
is this still a problem?
Assignee: ssu0262 → general
OS: other → OS/2
yes
Attached patch Fix for problem (obsolete) — Splinter Review
Pass TRUE to the DirectoryRemove so we remove any directories underneath.
Assignee: general → mkaply
Status: UNCONFIRMED → ASSIGNED
It still wasn't deleting the directory because the OS/2 API can't handle a
directory like x:\blah\ - it has to be x:\blah
Attachment #143337 - Attachment is obsolete: true
Attachment #143441 - Flags: review?(pedemont)
Attachment #143441 - Flags: review?(pedemont) → review+
Fix checked in.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: