Crash shutting down in layout module

VERIFIED DUPLICATE of bug 19183

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 19183
18 years ago
18 years ago

People

(Reporter: scottputterman, Assigned: Suresh Duddi (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Sometimes when I view certain messages (I will try to find a message where this
happens so I can attach it), I get the following crash.  It's because
nsTextTransformer::Shutdown() is using the ServiceManager after the
ServiceManager has been destroyed.

nsServiceManager::ReleaseService(const nsID & {...}, nsISupports * 0x017faf50,
nsIShutdownListener * 0x00000000) line 510 + 26 bytes
nsTextTransformer::Shutdown() line 103 + 19 bytes
nsLayoutModule::Shutdown() line 262
nsLayoutModule::~nsLayoutModule() line 172
nsLayoutModule::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsLayoutModule::Release(nsLayoutModule * const 0x017ded00) line 174 + 134 bytes
nsDll::Shutdown() line 394 + 18 bytes
nsFreeLibrary(nsDll * 0x01014500, nsIServiceManager * 0x00000000, int 3) line
353
nsFreeLibraryEnum(nsHashKey * 0x010143f0, void * 0x01014500, void * 0x0012fde8)
line 401 + 64 bytes
_hashEnumerate(PLHashEntry * 0x010143b0, int 5, void * 0x0012fdd0) line 89 + 26
bytes
PL_HashTableEnumerateEntries(PLHashTable * 0x01005b90, int (PLHashEntry *, int,
void *)* 0x1001b890 _hashEnumerate(PLHashEntry *, int, void *), void *
0x0012fdd0) line 368 + 15 bytes
nsHashtable::Enumerate(int (nsHashKey *, void *, void *)* 0x1004c5d0
nsFreeLibraryEnum(nsHashKey *, void *, void *), void * 0x0012fde8) line 218 + 20
bytes
nsNativeComponentLoader::UnloadAll(nsNativeComponentLoader * const 0x01004190,
int 3) line 883
nsComponentManagerImpl::UnloadLibraries(nsIServiceManager * 0x00000000, int 3)
line 1951 + 22 bytes
nsComponentManagerImpl::Shutdown() line 278
NS_ShutdownXPCOM(nsIServiceManager * 0x00000000) line 539 + 11 bytes
main(int 1, char * * 0x01004e00) line 688 + 8 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77f1ba06()
(Reporter)

Comment 1

18 years ago
I meant to say that after I view certain messages and then shut down the app, I
crash.
(Assignee)

Updated

18 years ago
Assignee: troy → dp
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M12
(Assignee)

Comment 2

18 years ago
It is valid to call releaseservice at shutdown.

This looks more like at shutdown time, xpcom should deal with keeping the global
servicemanager variable in sync.

I will take this bug.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

18 years ago
We have been dicussing situations like these in bug# 19183 Please could you add
your input to the discussion. thanks.

*** This bug has been marked as a duplicate of 19183 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 4

18 years ago
Agreed.Marking as verified dup of 19183.
You need to log in before you can comment on or make changes to this bug.