css not handled correctly

RESOLVED DUPLICATE of bug 163110

Status

()

RESOLVED DUPLICATE of bug 163110
16 years ago
16 years ago

People

(Reporter: gerrit, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425

This page has lines of text that break not according to the css stylesheets. The
text has a floating div  next to it and it looks like Mozilla takes the length
of the url embedded in the main text into account. 
Iexplorer and Opera show the correct formattaing of that page

Reproducible: Always

Steps to Reproduce:
1. go to the webpage provided
2. open Opera or Iexplorer
3. open the same page
4. compare difference

Actual Results:  
See the described problem

Expected Results:  
see the display in Opera or Iexplorer
-> Style System (or Layout ?)
Assignee: adamlock → dbaron
Component: Embedding: APIs → Style System
QA Contact: carosendahl → ian

Comment 2

16 years ago
This WFM on WinXP build 20030507.  Try testing the site with a more recent 
version (1.4b).
(Reporter)

Comment 3

16 years ago
tested on Win 2000 Mozilla 1.4b, same result. 

Comment 4

16 years ago
Someone else had a layout problem that was solved by changing themes.  Are you 
using a theme other than the default?
(Reporter)

Comment 5

16 years ago
Used the default (modern) them, changing it to classic (ugh) did not help

Comment 6

16 years ago
OK, can you attach a) a screenshot of the page, and b) a testcase to 
demonstrate the problem?  That'll really help.
WFM. This page looks the same in Moz 1.4b and Opera 7.11-final on GNU/Linux.

Comment 8

16 years ago
Created attachment 123589 [details]
Testcase

Comment 9

16 years ago
LI with margin-right next to a floater.
Assignee: dbaron → float
Component: Style System → Layout: Floats
Keywords: testcase
OS: Windows 2000 → All
Hardware: PC → All

Comment 10

16 years ago
Maybe this bug should be added to bug 78094 (float meta bug), but don't know 
enough to try and dupe this against any of those dependencies.
(Reporter)

Comment 11

16 years ago
 For a complete test and description of the source of the issue
http://xml.kuilder.net/bookmusicetc/indextest.html
See bug 163110 and its ilk.
Depends on: 163110

*** This bug has been marked as a duplicate of 163110 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
No longer depends on: 163110
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.