Bug reporting menu appears at startup, then disappears.

VERIFIED DUPLICATE of bug 204418

Status

()

VERIFIED DUPLICATE of bug 204418
16 years ago
12 years ago

People

(Reporter: philb1701, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

When Firebird first starts up, the menu bar offers a bug menu, then just prior
to the first window drawing, it disappears.

Reproducible: Always

Steps to Reproduce:
1. Start up Firebird.
2.
3.

Actual Results:  
The bug menu momentarily appears, then disappears just prior to the first window
being mounted.

Expected Results:  
Kept the bug menu available.

Comment 1

16 years ago
Phil, do you mean the Debug and QA menus?

(if so this looks like a dupe of bug 204418)

Comment 2

16 years ago
As we don't have a initial "bug menu" I suppose this to be the "Debug menu"
mentioned in comment #1 and hence I suppose this to be a dupe of bug #204418.

Phil, if bug #204418 doesn't cover your issue please feel free to reopen this bug!

*** This bug has been marked as a duplicate of 204418 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
From bug 206186:
various menus can be seen which are sometimes usable, sometimes not.

Not quite the same as what I am experiencing.  The bug reporting menu appears for a 
brief period at opening Firebird, and if you are quick enough, you can get to it.  
Otherwise, it disappears when the first window is mounted.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

16 years ago
Phil, what is this "bug reporting" menu you speak of? Is this menu different in
content from the menu that appears when no Firebird browser windows are open?


If this is the Debug and and QA menu items then this is indeed a dupe as fixing
bug 204418 involves removing those "Mozilla" menu items completely.

Comment 5

16 years ago
Ok Phil - so we'll give it another try ;) If you're quick enough you can get
into these menus you'd also be able to make a small screenshot of the menu bar
before these menu entries vanish - perhaps this is a better way to find out,
what's going on on your side...
(Reporter)

Comment 6

16 years ago
Created attachment 123786 [details]
Two menu bar illustrations.

The top menu bar illustrates the menus without a window.

The bottom shows the menu bar with a window open.

Comment 7

16 years ago
Thanks, Phil - so what do you mean by "bug menu"? I just see an additional
"Window" entry in the top menu bar and that seems to be the whole difference
between both screenshots... 

Please note that I had to use Netscape 4.51 in order to be able to view the
attachment as both Mozilla Firebird and IE 5.5 reported an error when trying to
view the attachment - so perhaps I didn't get the whole image shown...
Perhaps you can upload the next screenshot (if necessary ;o) ) with a different
format?

Comment 8

16 years ago
I think this is a dupe of bug #204418. What you're seeing is probably the
Communicator menubar which is used when there are no visible windows. It makes
sense that you'd see this at startup if Firebird loads the hidden window and
flashes its menubar on slower machines before showing the first window.
(Reporter)

Comment 9

16 years ago
Created attachment 123803 [details]
Screen shot of Firebird menu bars

First screen bar is the Firebird menu with a browser window open.

Second screen bar is the Firebird menu with no browser window open.  Note the
additional menu optioins.  I have since been told that this is the Communicator
menu bar, which still doesn't explain why it changes according to whether a
window is open or not.	As far as slower machines is concerned, I would hardly
call a 933Mhz G4 slow, but no matter.

Thanks for your patience in working with me on this one.

Phil

Comment 10

16 years ago
Phil, from the second attachment this is a clear duplicate of bug #204418 - what
are the differences between both bugs? 

Compared to the upper menubar you've got three additional menu entries "Window",
"Debug" and "QA" in the lower menu bar which all came from SeaMonkey - and this
will be covered and fixed by bug #204418!
Just download and start latest SeaMonkey and you'll see exactly the same menu as
in your second menu bar shown in the attachment!

If you've got no additional reasons why this should be kept as a seperate bug
I'll resolve this one as duplicate again.

Comment 11

16 years ago

*** This bug has been marked as a duplicate of 204418 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
mass-verifying
Status: RESOLVED → VERIFIED
Taking QA Contact as designated owner of Firebird-Menus. Sorry for bugspam.
QA Contact: asa → bugzilla

Updated

12 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.