directory name off-by-one in profile manager "create new profile"

VERIFIED DUPLICATE of bug 200439

Status

SeaMonkey
Startup & Profiles
VERIFIED DUPLICATE of bug 200439
15 years ago
14 years ago

People

(Reporter: Martin Pool, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Dillo/0.7.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

I chose the

Reproducible: Always

Steps to Reproduce:
1. Run MozillaFirebird -ProfileManager
2. Choose "Create new profile"
3. Enter some text in the profile name and watch the directory underneath "Your user settings etc will be stored in"
Actual Results:  
The directory name "lags" my entry by one character.  As I enter text, it shows all but the last character.  Similary when deleting or changing existing text.

It's like it is triggering off the "field changed" event, but is looking at the contents before the change, rather than afterwards.

The directory is created with the correct filename based on the profile name and not the one that is displayed.  So this is only a cosmetic bug, but a slightly disturbing one.

Expected Results:  
It ought to update in lockstep with the name of the profile.

Comment 1

15 years ago
dupe of "Last character typed in text field when creating new profile is not
displayed in target location"

*** This bug has been marked as a duplicate of 200439 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
What can I say, I did search for dupes first but obviously I missed it.

Thanks for a great bit of software!

Comment 3

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.