printing pegs the cpu and effectively hangs the browser

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
16 years ago
11 years ago

People

(Reporter: mtk, Unassigned)

Tracking

({hang})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507

if you try to print http://www.mozilla.org/projects/firebird/why/,
the cpu is pegged at 100% and the browser is effectively hung.
this is on a dual 2.4GHz box with 2G of dual-channel rambus
memory, so it "hangs" very quickly :-).

Reproducible: Always

Steps to Reproduce:
1.visit the page.
2.print it.
3.go for a cup of coffee
Actual Results:  
one of two cpus (it's a dual cpu box) is pegged at 100%. browser doesn't
respond to any input events.  can't cancel the print dialog, can't 
close the browser at all.  have to 'kill' it to make it go away.

Expected Results:  
printed the page.

Comment 1

16 years ago
WFM LInux 2003051611

Comment 2

16 years ago
Reporter:
Can you provide a stack trace from the "hung" Mozilla, please ?

Comment 3

16 years ago
worksforme with linux trunk 20030519 and 1.4b
Severity: normal → critical
Keywords: hang

Comment 4

15 years ago
Confirming bug, 2003-11-10-05 trunk Linux.  Print Preview of URL => 100% CPU.
Status: UNCONFIRMED → NEW
Depends on: 185357
Ever confirmed: true
(Same with Gamespot.com on Windows XP, Seamonkey build 2004-06-20-08.)

Comment 6

14 years ago
WFM, win98se, Trunk 2004-09-30 (1.8a5)

Comment 7

14 years ago
*** Bug 264377 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
When duping bug 264377 i found some other problems with gamespot. Is there any
relation between this bug and bug 132337?

Comment 9

11 years ago
WFM.  please try this on the latest trunk 20070613
The URL that was mentioned in this bug for the hang does not exists now. Its now a 404 link.

Closing this because of comment #6 and #9 as works for me. Feel free to reopen this bug if you can reproduce this reported bug in a latest Trunk build.

Please include a testcase or valid url then.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.