Closed Bug 206401 Opened 17 years ago Closed 17 years ago

Save as Complete Web Page doesn't alter relative URLs specified in external CSS file

Categories

(Core Graveyard :: File Handling, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 115107

People

(Reporter: deleeuw+bugzilla, Assigned: adamlock)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030515
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030515

If you save a page as a complete web page, that process alters the original
HTML, paths and stuff are altered to [web page name]-files.

But, if a relative URL is specified in a CSS file, residing in that [web page
name]-files directory, those relative URLs does not get altered, and will point
to invalid locations.

Reproducible: Always

Steps to Reproduce:
1. Save the specified URL above as a complete web page.
2. Look at the saved webpage in Mozilla.


Actual Results:  
The page looks completely different due to the fact that mozilla doesn't alter
the  relative URL in CSS files.

Expected Results:  
Altered the relative URLs in CSS files.
The opposite problem (dependent file in wrong place) is in
Bug 206319. Seems component here should be "File Handling." 
--> default owner
Assignee: general → law
Component: Browser-General → File Handling
QA Contact: general → petersen
The only url I see in the css file is
background-image: url(http://www.scottandrew.com/img/bg_sunflower_02.jpg);
Dupe of Bug 115107.
Sorry, bad example, but still, the save operation does not alter relative URLs 
in CSS files.
-->adamlock for duping or adding dependencies
Assignee: law → adamlock
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
dup of bug 115107 "CSS not fixed up by webbrowserpersist (background images not
saved)"

*** This bug has been marked as a duplicate of 115107 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.