attachment.cgi crashes when uploading certain PDF files

RESOLVED INVALID

Status

()

Bugzilla
Attachments & Requests
--
trivial
RESOLVED INVALID
15 years ago
6 years ago

People

(Reporter: Vaskin Kissoyan, Assigned: myk)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

I'm not sure that it is related but we upgraded from 2.17.3 to 2.17.4 recently
and this has not happened before with the same people making the same types of
PDFs. We use PDFs quite often in our bugzilla instance.

We get an Apache server error 500, and the error log, after doing:
tail -f error.log | strings reveals the following:

\rendstream\rendobj\r11 0 obj\r1021432\rendobj\r8 0 obj\r<<\r/Length 12 0 R
>>\rstream\rendstream\rendobj\r12 0 obj\r0\rendobj\rxref\r0 13\r0000000000 65535
f \r0000000009 00000 n \r0000000188 00000 n \r0000000058 00000 n \r0000000246
00000 n \r0000003161 00000 n \r0000003053 00000 n \r0000000652 00000 n
\r0001024807 00000 n \r0000003033 00000 n \r0000003142 00000 n \r0001024783
00000 n \r0001024860 00000 n \rtrailer\r<<\r/Size 13\r/Root 1 0 R\r/Info 3 0
R\r>>\rstartxref\r1024878\r%%EOF\r')'']) at Bugzilla/DB.pm line 66
 Bugzilla::DB::SendSQL('INSERT INTO attachments (bug_id, creation_ts, filename,
descr...') called at /home/bugzilla/www/attachment.cgi line 521
 main::insert('%PDF-1.3\x{d}1 0 obj\x{d}<<\x{d}/Type /Catalog\x{d}/Pages 2 0 R
>>\x{d}endobj\x{d}3 0...') called at /home/bugzilla/www/attachment.cgi line 106
[Tue May 20 12:45:17 2003] [error] [client 192.168.192.100] Premature end of
script headers: /home/bugzilla/www/attachment.cgi




Reproducible: Always

Steps to Reproduce:
1. Create an attachment link on an existing bug
2. Attach a specific file:

3. select binary/octet-stream or auto-detect
4. click submit


Actual Results:  
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to
complete your request.

Please contact the server administrator, webmaster@lokion.com and inform them of
the time the error occurred, and anything you might have done that may have
caused the error.

More information about this error may be available in the server error log.

Apache/1.3.19 Server at issues.viking.lokion.com Port 80

Expected Results:  
Successfully Created attachment # whatever.

I am going to try to attach this "specific file", but I may have to put it on a
public server somewhere or just email it to people cause I bet it won't attach
on this bug. I'm not sure if it will or not since I thinkg b.m.o is still on
2.17.3... we'll see.
(Reporter)

Comment 1

15 years ago
we think this is related to size of the file.

I have parameters set to allow about 10MB of files, but the upgrade from 2.17.3
to 2.17.4 required a MySQL upgrade which somehow I bet changed or lost the
parameter that needs to be set in MySQL for allowing such large blobs.
(Reporter)

Comment 2

15 years ago
/etc/my.cnf:

set-variable = max_allowed_packet=16M

This is the max for MySQL 3.x, change the # of MB as you see fit.

Still, I don't think bugzilla should crap-out like that, it should detect the
MySQL configuration.
Are you still seeing this?  I'm almost positive this happens when your
maxattachmentsize param in editparams.cgi is set larger than your max packet
size in the MySQL config.  Make sure the Bugzilla parameter is smaller than the
MySQL one.  I'll assume that was the case and close this in a week if I don't
hear anything further.
OS: Windows 2000 → All
Hardware: PC → All
(Reporter)

Comment 4

15 years ago
yes that was the issue. I'm sorry I didn't close this sooner.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Severity: major → trivial
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.