Last Comment Bug 206516 - change display property to none and block breaks table cell rendering
: change display property to none and block breaks table cell rendering
Status: VERIFIED FIXED
: testcase
Product: Core
Classification: Components
Component: Layout: Tables (show other bugs)
: Trunk
: x86 Linux
: -- normal with 2 votes (vote)
: ---
Assigned To: Bernd
: Madhur Bhatia
:
Mentors:
http://web.rantac.com.br/ab/bug.html
Depends on: 162063 reflow-refactor
Blocks: 300909
  Show dependency treegraph
 
Reported: 2003-05-20 15:59 PDT by Osvaldo Santana Neto
Modified: 2007-03-09 18:04 PST (History)
7 users (show)
bzbarsky: blocking1.8b4-
bzbarsky: blocking1.8b5-
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase (2.68 KB, application/gzip)
2004-02-04 13:03 PST, Osvaldo Santana Neto
no flags Details
testcase html file (4.76 KB, text/html)
2004-02-06 03:43 PST, Osvaldo Santana Neto
no flags Details
testcase css file (4.33 KB, text/css)
2004-02-06 03:45 PST, Osvaldo Santana Neto
no flags Details
testcase js file (973 bytes, application/x-javascript)
2004-02-06 03:45 PST, Osvaldo Santana Neto
no flags Details
HTML file in usable form (pointing to the other 2) (4.87 KB, text/html)
2004-02-06 07:38 PST, Boris Zbarsky [:bz] (still a bit busy)
no flags Details
reproduces bug (546 bytes, text/html)
2004-04-30 09:37 PDT, Daniel Santos
no flags Details
reduced testcase (380 bytes, text/html)
2005-07-12 00:06 PDT, Bernd
no flags Details
patch (1.12 KB, patch)
2005-07-16 09:16 PDT, Bernd
roc: review+
roc: superreview+
Details | Diff | Splinter Review
Reftests (1.39 KB, patch)
2007-03-06 15:27 PST, Ryan VanderMeulen [:RyanVM]
no flags Details | Diff | Splinter Review
Reftests round 2 (1.36 KB, patch)
2007-03-06 15:34 PST, Ryan VanderMeulen [:RyanVM]
dbaron: review+
Details | Diff | Splinter Review

Description Osvaldo Santana Neto 2003-05-20 15:59:41 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030317
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030317

Try check/uncheck for many times the radioboxes in page:
http://r2d2.rantac.com.br/ispman/bug.html and you will see the problem.

Reproducible: Always

Steps to Reproduce:
1. enter in http://r2d2.rantac.com.br/ispman/bug.html
2. check/uncheck radioboxes in page (many times)
3. done

Actual Results:  
The page render crashes (table column)

Expected Results:  
Disable/Enable table columns visibility.
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2003-05-20 21:32:29 PDT
The page is setting table elements (tr and td) to be display:block.  We have
some existing issues with this (not disposing of pseudo-frames properly), but
even if those were fixed the page layout would still be "broken" (because CSS
table display types are completely broken in IE and the page expects the IE
behavior).  Using table-row and table-cell for the display, as appropriate, will
work in Mozilla and other CSS2-compliant browsers (but not in CSS1 browsers like
IE/Windows).

Over to tables to dup to the bug on pseudo-frame issues.
Comment 2 Madhur Bhatia 2003-05-28 12:29:23 PDT
checked the url on winXP and Linux on 2003-05-28trunk builds 
WFM!

Osvaldo, please check this again in the latest build and if u do get a crash,
provide the talkback crash id number or the stack signature.
Comment 3 Bernd 2003-08-16 13:43:10 PDT
testcase has gone :-(
Comment 4 Osvaldo Santana Neto 2003-08-16 14:35:59 PDT
Sorry for incovenience.

The testcase has moved to:
http://web.rantac.com.br/ab/bug.html
Comment 5 Bernd 2004-02-04 10:08:13 PST
Osvaldo could you please attach the testcase to the bug just hit the Create a
New Attachment link and follow the instruction. I suspect however that this bug
is a dupe of 77019 which hopefully will be fixed in a near future
Comment 6 Osvaldo Santana Neto 2004-02-04 13:03:43 PST
Created attachment 140618 [details]
Testcase
Comment 7 Bernd 2004-02-05 22:37:28 PST
Osvaldo, is your testcase just a html page? attach the html instead of the
archive please. I can't open the archive.
Comment 8 Osvaldo Santana Neto 2004-02-06 03:43:56 PST
Created attachment 140740 [details]
testcase html file
Comment 9 Osvaldo Santana Neto 2004-02-06 03:45:02 PST
Created attachment 140741 [details]
testcase css file
Comment 10 Osvaldo Santana Neto 2004-02-06 03:45:29 PST
Created attachment 140742 [details]
testcase js file
Comment 11 Osvaldo Santana Neto 2004-02-06 03:46:37 PST
the testcase is:
1 .html
1 .css
1 .js

I will attach the 3 items separated...
Comment 12 Boris Zbarsky [:bz] (still a bit busy) 2004-02-06 07:38:37 PST
Created attachment 140746 [details]
HTML file in usable form (pointing to the other 2)
Comment 13 Boris Zbarsky [:bz] (still a bit busy) 2004-02-06 07:42:07 PST
Resummarizing to make it clear what the bug is about.  Testcase never uses
"visibility" and this has nothing to do with bug 77019
Comment 14 Daniel Santos 2004-04-30 09:37:18 PDT
Created attachment 147399 [details]
reproduces bug
Comment 15 Daniel Santos 2004-04-30 09:39:13 PDT
Windows XP and 2000, current Mozilla and Foxfire. I could not get a crash, but I
get the described layout problems. Can we move this to confirmed? (attached
another reproduction case)
Comment 16 Boris Zbarsky [:bz] (still a bit busy) 2004-04-30 09:58:55 PDT
We can't move it to confirmed, since it's a duplicate (at least the layout
problems in your testcase are duplicates).  Note the DUPEME keyword.

Also note that even if the layout problems were fixed your testcase would still
be "broken" because putting both of those cells in the first column when that
"show" function runs is correct per the CSS spec.
Comment 17 Bernd 2005-07-12 00:06:43 PDT
Created attachment 189025 [details]
reduced testcase
Comment 18 Bernd 2005-07-16 09:16:24 PDT
Created attachment 189538 [details] [diff] [review]
patch

This fixes a problem in block layout, but leaves the frame construction issue.
The block problem is that the block caches the mAscent and if there are no
lines inside the block the cached value is reported to the containing table
cell.
Comment 19 Boris Zbarsky [:bz] (still a bit busy) 2005-07-17 08:31:10 PDT
Bernd, you want to spin that off into a separate bug, or check it in under this one?
Comment 20 Bernd 2005-07-17 08:42:21 PDT
Just the block reflow issue here and 162063 for the frame issue. The fix here
will not complete give the space back as the remaining anonymous table cells
will have their cellpadding cellspacing still applied.
Comment 21 Bernd 2005-08-30 10:26:20 PDT
fix checked in the reminder is bug 162063
Comment 22 Mathieu Parent 2005-08-31 09:35:41 PDT
Maybe this should be done on branch

the patch seems to be simple (any regression) ?

REOPEN ?
Comment 23 Boris Zbarsky [:bz] (still a bit busy) 2005-08-31 09:45:36 PDT
> Maybe this should be done on branch

If you feel that way, request approval for the patch (see the flags on the patch
itself) and explain in the approval request why this is needed and why it's very
safe.

> the patch seems to be simple (any regression) ?

We probably won't know for at least a few weeks.  Unless you have a source of
knowledge I'm not aware of.

> REOPEN ?

Why?  It's fixed.  Whatever happens on branch doesn't affect the resolution,
which tracks things on trunk.

Not a branch blocker in any case, unless this is a very common problem out
there.  If it is, please point out the sites broken by it.
Comment 24 Bernd 2005-11-19 10:21:39 PST
The reduced testcase shows red again. As I did not checkin the test into the layout regression tests I can not pinpoint when this went bad again.
Comment 25 Daniel Veditz [:dveditz] 2006-03-15 21:28:31 PST
"DUPEME" seems obsolete if work's going on here.
Comment 26 Bernd 2006-12-16 23:35:43 PST
the regression in the reduced testcase has been fixed by the reflow branch
Comment 27 Ryan VanderMeulen [:RyanVM] 2007-03-06 15:27:37 PST
Created attachment 257571 [details] [diff] [review]
Reftests

These are based on the last testcase posted to this bug. I'm a bit concerned that this test will have to be marked as random, though. I've noticed that when I load the test, if I refresh the page quickly, I will sometimes see a very brief flash or red under the green cell. Depending on when the reftest takes the screenshot, that might pose a problem.
Comment 28 Ryan VanderMeulen [:RyanVM] 2007-03-06 15:34:36 PST
Created attachment 257572 [details] [diff] [review]
Reftests round 2

Whoops, forgot to remove the table background color from the reference
Comment 29 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2007-03-09 16:42:50 PST
Comment on attachment 257572 [details] [diff] [review]
Reftests round 2

Checked in after testing in pre- and post-reflow-branch builds.

Note You need to log in before you can comment on or make changes to this bug.