Get into a state where content of msg no longer loads in message pane

VERIFIED WORKSFORME

Status

MailNews Core
Networking
P2
major
VERIFIED WORKSFORME
18 years ago
7 years ago

People

(Reporter: lchiang, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Description

18 years ago
Get into a state where content of msg no longer loads in message pane

I started noticing this about 4 (?) or so days ago.  Filing a bug now even
though I don't have the exact reproducible steps.  (I've tried and will continue
to try to narrow down)

Linux build 1999-1202-08-m12.
IMAP account
Does not matter whether 5.0 is installed locally or not. Does not matter if
.mozilla directory is local or not.  I tried all combinations.

Here are some basic steps of what I usually do when I see the problem:

1)  Start mail
2)  Select Inbox and log in
3)  Read and delete a few messages
4)  Try to select another message
5)  The message is selected in the thread pane, but is not loaded in the message
pane.  From this point forward, you cannot load/display any other messages.

Note: You are able to do other things such as change folders.

I've shown this to Seth already.

Comment 1

18 years ago
isn't this the same problem as the one reported on the Mac
and akkana's bug on linux? (20546) and 20649?
I'd like to mark this as a dup of 20546 unless someone objects...
(Reporter)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

18 years ago
ok, I'll do so.  I thought it may be different since Akkana can never load a
single msg, but I can.  I only run after this problem after some use.


*** This bug has been marked as a duplicate of 20546 ***
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
Status: VERIFIED → REOPENED
re-open, I don't think this what akkana was seeing because for her, the message
never loads, for this bug, it just stops working.

akkana's bug is no longer happening, and I don't want to lose this bug.
Resolution: DUPLICATE → ---
note to self, this has something to do with biff, set biff time interval to 1
minute to help reproduce.
Target Milestone: M14
this is hard to reproduce, so marking m14, not dogfood.

unless it starts happening to more people.

my guess so far is that biff and switching messages in the thread pane cause
some sort of deadlock.  (wild guess, to remind me what I was thinking when I get
back to this bug.)

Comment 6

18 years ago
I've experienced this when reading news messages.  It usually happens after I've
read about four groups with 8 or so new messages in each.  I'll select the next
header and the spinner fires up but no message is loaded.  No combination of
selecting other groups or messages seems to remedy the problem so I've just
gotten in the habit of closing mail and firing it right back up. It always
functions properly after I restart it.  I will try to pay closer attention to my
usage pattern and maybe get something reproducable.  This problem shows up for
me on win32 builds from the last week at least running on win98.  Adding myself
to cc: list.
asa, if you are seeing this when in news, I think it is another bug.

when you get into this state, does clicking twice on the splitter between the
thread pane and message pane help?  (to close and then to open)

a while back we had a problem where I was leaving open connections to the nntp
server, which meant after a while, it would stop working because the server
rejected my connections.

but I don't think that is this.

Comment 8

18 years ago
If this is a seperate bug I can report it.  Nothing I've tried, including
opening and collapsing both splitters, switching to a different newsgroup,
switching to mail, will let me load another news message.
Priority: P3 → P2
marking p2
moving to m15
Status: REOPENED → ASSIGNED
Target Milestone: M14 → M15

Comment 11

18 years ago
I'm seeing this today using 2000-03-09-13m15 commercial build on linux. I'm
involved in verifying Move/Copy within and among servers and after a few Move
Message and/or undos of a move I can't get another selected message to load
content in the message pane. I'm also switching between the move's origination
and destination folders.

Updated

18 years ago
QA Contact: lchiang → laurel
I think that I understand this (and bug #30648)

see bug #30648

if you do about 50 operations on something based on nsMsgProtocol.cpp, (so pop, 
smtp or nntp, but NOT imap) you will end up getting into this state.

Comment 13

18 years ago
Lisa mentioned she was having a problem where delete stopped working in today's
afternoon win32 build using IMAP.  Delete stops working.  

I reproduced on both NT 4.0 and linux rh6.0 a few times.  Using IMAP, delete
about 10 messages.  Delete stops working, but... in some tries I could select
other messages, have the message pane load contents and do a move message (which
deletes, eh?).  In some tries I could no longer select any message. And finally,
the last couple times I tried to reproduce I couldn't -- I was successfully able
to delete about 35 messages and delete didn't stop on me.

I might guess this is the same problem as this #20653 and/or #30648, although
you mentioned in your comments "but NOT IMAP".  

Seth or Scott P.: let me know if you think this should be logged separately.
(Reporter)

Comment 14

18 years ago
as is, I'm going to mark this beta1  It's very bad now because I can't delete 
many messages in daily use (as per laurel's last comments).  If you want this 
split into a separate bug, let me know.  I noticed this about two builds ago.  
Cannot delete/move on IMAP after a few deletions.
Keywords: beta1

Comment 15

18 years ago
I can't get into the state where I can't load a message but I can get into the 
state where I can't delete.  The reason is because at some point m_copyState in 
the trash folder isn't getting cleared out which causes 
nsImapMailFolder::InitCopyState to return NS_ERROR_OUT_OF_MEMORY which cuts the 
delete short.  cc'ing jefft for any ideas.

Comment 16

18 years ago
I wonder if the deleting bug is the same as 24456 which is already filed against 
me?
I'll investigate this today.
actually, it looks like putterman is on top of this.

putterman, do you want any help investigating this, or should I re-assign to 
you?

Comment 19

18 years ago
actually, I think these are 2 different bugs.  i can't reproduce this bug.  I
can reproduce the delete bug which is already assigned to me.  I guess I'm just
saying that we should consider these as separate bugs and talk about delete in
24456.
ok, then I'll work to reproduce the "get into a state where you can't load any 
imap messages" bug.

Comment 21

18 years ago
Lisa nominated this bug for beta1 because she couldn't delete some messages or
am I misunderstanding something. Since we are keeping the delete problem
separate in another bug, can we remove the beta1 nomination from this bug?


Comment 22

18 years ago
I think we should keep it here.  We don't really want a beta1 nomination on the
other bug :)

Comment 23

18 years ago
I don't think either of them warrant beta1 nominations at this point in the game
=). Neither problem causes a crash or data loss. Unless the fix is trivial and
ultra safe, I doubt we'll get a + on either problem....

Just make sure that putterman guy has as many PDT+ bugs as Stanford has losses
to Arizona this year. Oh wait...that was harsh...I'm sorry.

Comment 24

18 years ago
What seed will MIT be getting in the tournament this year?
(Reporter)

Comment 25

18 years ago
I'll remove beta1 here then.  The other bug says "thread view, can't delete".  
I'm sorted by date.
Keywords: beta1

Comment 26

18 years ago
Now that was really weak. Everyone knows MIT is too bright to waste time on
basketball. What happens if one of those engineers breaks a wrist or something
playing basketball! Before you know it they can't work on their problem sets
because they can't type! Oh wait, that story sounds too familiar.



Keywords: beta1
laurel / lisa:  is there a good way to reproduce the "messages won't load" 
problem?

Comment 28

18 years ago
Using yesterday's linux commercial build, I just was able to reproduce by:
1.  Launch mail and login to an IMAP account, go to a folder with 100 or so junk
messages. 
2.  Message pane is open. Select first message.
3.  Delete each message in sequence. Note that the next message is selected and
the proper message contents are drawn in message pane.
4.  Keep deleting messages in sequence and eventually (about 30-50 messages ?)
you will notice Delete button won't work anymore.
5.  At this point, select another message in the thread pane.  The thread pane
selection will change but not message pane.  At this point I tried switching to
another folder and thread pane refreshed but could not get message contents when
message was selected.  
thanks for the info laurel.  I'll start debugging now.

the number (50) is suspicous.  50 is the max number of active connections we 
allow.  I wonder if we are hitting that limit in the case you describe.  I'll 
know for a sure in a few minutes.

see bug #30648 for more details.

Comment 30

18 years ago
Putting on PDT- radar for beta1.
Whiteboard: [PDT-]
still haven't found time for this bug.  moving to m16.
Target Milestone: M15 → M16

Comment 32

18 years ago
Moving out of M16.  Nominate for beta2 if you think this must make beta2.
Target Milestone: M16 → M17

Comment 33

18 years ago
Lisa says we can mark this WORKSFORME.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 34

18 years ago
Well, when trying to make sure this was gone I ran into a crash at about the
50th message two tries in a row.  I guess I'll mark this verified and open a new
bug, since it's likely the crash is a different cause than this bug originally
was.

Marking verified (worksforme). 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.