Mail fails after first POP3 receipt w/ clocking cursor and sometimes "Folder being processed" error.

RESOLVED WORKSFORME

Status

MailNews Core
Networking: POP
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Werner L. Stunkel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3.1) Gecko/20030425

After commanding Mail to recieve all mail for three addresses, the subsystem
retains clocking cursor and subsequent attempts to recieve mail require exiting
Moz and restarting. Often, the clocking condition is blocking further mail receipt.

Note that the clocking folder will not respond to "Get Messages" button.

If there is no mail waiting, the condition does not occur and the mail system
appears normal. 



Reproducible: Always

Steps to Reproduce:
1.Open Mail
2.Select "Get all new messages"
3.Result is as described in "Details".

Actual Results:  
Clocking cursor; one of three addresses may report "Folder being processed" (or
similar message) on subsequent attempts to recieve mail. 

Expected Results:  
Should behave as in V1.3 with reliable mail receipt and no clocking folders.

Bug also in V1.4b. Anecdotal evidence that preferences do not load correctly
throughout 1.4b.

This mail account does not have any of the automatic mail check or download
features enabled. I thought perhaps they were causing the problem, but changing
these had no effect on the problem.
(Reporter)

Comment 1

15 years ago
Clocking cursor appears only when offending folder is open (Top-right panel).
Other folders have a normal arrow cursor. The problem is most often in the first
account/folder (my busiest), but not exclusively there.

Again, symptom was also in V1.4b.

Comment 2

15 years ago
please update to a 1.4 final build - I suspect this is a dup and is fixed.
(Reporter)

Comment 3

15 years ago
I tried 1.4b, if that is the "final release" of which you speak. Same problem.

Comment 4

15 years ago
I am getting this exact problem.  I have never experienced this until upgrading
to Mozilla 1.4b.

I have muliple POP accounts also.  When it gets to this state I have to go into
the task manager and kill the mozilla process in order to be able to retrieve
mail again.  Upon retrieving mail once, it reverts back to this problem.

Comment 5

15 years ago
This is not specific to the Macintosh version. I get the same problem with
Windows XP. I went back to version 1.3 in case it was specific to 1.3.1, but the
problem
still remains.

Comment 6

15 years ago
Yes, I should have made that clear... it happens with WinXP.

Comment 7

15 years ago
If I turn off the "Keep Mozilla In Memory Option" at least I can reset it by
shutting down all instances of Mozilla and restart it without going into the
task manager.

Comment 8

15 years ago
This is probably bug 205379 - same symptoms for me.

Comment 9

15 years ago
Looks like a dup - are you using attbi/comcast?
Component: Mail Window Front End → Networking: POP
OS: MacOS X → All
Hardware: Macintosh → All
(Reporter)

Comment 10

15 years ago
My mail is obviously ATTBI.COM. How can this be an issue? POP3 is an "open
standard", is it not?

I do not know what kind of server they use... wouldn't any ATT issue be generic
to their vendor's software? Mind you I am a half a hair from ditching them and
running POP3 on my Alphacluster, what with the ATT/COMCAST name change and very
poor customer support. Ditch another box of business cards....

Comment 11

15 years ago
please look at bug 205379 for problems with attbi - apparently their servers are
just disconnecting when we try various commands, which POP3 servers aren't
supposed to do, obviously.
I'm getting the same behaviour in one of my accounts, from my ISP (uol.com.br).
 I'm using:

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

The new info is: this only happens with automatic commercial ads sent by my ISP!

If there are "normal" messages in the queue, they are downloaded normally until
the first ad mail is reached.  This ad email is also downloaded, but the
download process hangs and the inbox folder gets the hourglass cursor as
described.  I also get "this folder is being processed" if I try to compact
folders on that account.

If I quit and restart mozilla and go to my ISP's webmail, the faulty message is
still there, although "Leave messages on server" is not checked.  If I remove
the message and try Mozilla Mail again, the same thing happens at the next ad
mail.  If I remove all those emails via the webmail, Mozilla handles the
"normal" messages fine as always.

The problem started when I upgraded from 1.4 to 1.5.  I did clean my previous
installation and created a new profile (I even deleted the profile folder before
installing).

I have four pop3 acconts: the first (and default) account is my ISP (uol.com.br)
account and the remaining three are yahoo.com.br accounts.

I'm willing to gather more information, as long as I'm told how :-) I have
cygwin installed, so using unix/gnu goodies is ok.  I suspect this has something
to do with the way they serve these emails, since I doubt such mass mail is
normally stored at the server.  (capturing a telnet to pop3, maybe?)

I've been using mozilla since pre-1.0 days, and I really want to keep using the
latest public release :-)

Comment 13

14 years ago
I experience the same problem on RedHat 9, using Courier (with Postfix Maildirs)
pop3 server, with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20030925. It is very annoying :-\ I can no longer use Mail & Newsgroups...
First mail retrieved, then the system goes to "This folder is being processed.
Please wait until processing is complete to get messages."

Comment 14

14 years ago
After a few restarts, I have restarted our mailserver and pop3 server. Nothing
happened, but when I have also restarted mozilla again, the issue automagically
disappeared.

Comment 15

14 years ago
This bug reapperad today. Now when I start Mail I get "downloading message 1 of
XXX". However, Mozilla does not even contact the mailserver (no signs of
activity in the maillog of the server). Then it waits forever. If I click on
"Inbox", the list of mails disappear and there is the hourglass showing for hours...

Comment 16

14 years ago
Rogério, your problem looks a little bit different than Csongors or Werners to me.
Your problem might have been fixed by the patch of bug 223060. It would be great
if you could test a recent trunk-nightly and report if that helps.

Of course it would not be amiss if all here experiencing a hang in a started
download would test this.

Comment 17

14 years ago
dupe of bug 152675
Product: MailNews → Core

Comment 18

11 years ago
are you still experiencing this bug ?
if so, does deleting all indexes (*.msf) fix it for a longer period of time ?
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody

Comment 20

10 years ago
(In reply to comment #17)
> dupe of bug 152675

Gabriel, of the reporter and commenters, only Fagyal's address works. If you feel this is a duplicate please go ahead and make the dupe.

Comment 21

10 years ago
I am no longer experiencing this bug (an yes, I am still using mozilla :)). It's been 4 years anyway :)

Comment 22

10 years ago
thanks Faqyal. so not duping.
=> WFM
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.