Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 20605
18 years ago
18 years ago

People

(Reporter: Mikael Widersten, Assigned: pnunn)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Windows NT SP6, 192 MB RAM. Mozilla M12 builds (as did M11) always crashes when
opening the given URL.

Comment 1

18 years ago
Created attachment 3197 [details]
minimal testcase
Assignee: leger → troy
Component: Browser-General → Layout
Summary: mozilla M12 crashes → mozilla M12 crashes
I'm not seeing the crash on Linux.  There are some display problems, though
(probably a view system bug).

Moving to Layout b/c the crash is on a specific page, and reassigning.

Comment 3

18 years ago
Hmm, the testcase doesn't crash as an attachment. Saving it to a local file
and then loading it should make mozilla crash though.

Comment 4

18 years ago
Here is a couple of stack traces:

img3250!IL_GetNaturalDimensions  (FPO: [1,0,3])
img3250!IL_Type  (FPO: [3,0,2])
img3250!IL_AddRefToColorSpace  (FPO: [3,0,0])
gkgfxwin!nsGetInterface::operator=
gkweb!nsQueryReferent::nsQueryReferent [omap]
[...]

And here is another one:

ntdll!RtlFreeHeap
!free
plc3!PL_strfree  (FPO: [1,0,0])
img3250!IL_Type  (FPO: [2,0,3])
img3250!IL_AddRefToColorSpace  (FPO: [2,0,0])
gkgfxwin!nsGetInterface::operator=
gkweb!nsQueryReferent::nsQueryReferent [omap]
[...]

Updated

18 years ago
Assignee: troy → pnunn

Comment 5

18 years ago
Another DUP of the image lib problem
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M12
(Assignee)

Comment 6

18 years ago
http://www.tucows.com/ads/DomainDirect/Nov99/COOLPET1.GIF
http://ads.tucows.com/image.ng/pageid=index
Those pesky banner ads.
Looks like it might be a dupe of bug#19394.
I'll be able to test once my build finishes.
-pn
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 7

18 years ago
Is a dupe. Has same callstack as 20605.
The url is a good test.
-pn

*** This bug has been marked as a duplicate of 20605 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 8

18 years ago
verified duplicate of 20605
You need to log in before you can comment on or make changes to this bug.