Illegal operation Mozilla will now shut down: ALL windows & tabs are frozen & lost

RESOLVED DUPLICATE of bug 19454

Status

defect
--
major
RESOLVED DUPLICATE of bug 19454
16 years ago
15 years ago

People

(Reporter: penguinistas, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3.1) Gecko/20030507

When Mozilla has to shut down due to an illegal operation, all Mozilla windows
and each of their tabs are frozen, killed, and can not even be viewed or saved
before being killed.

Reproducible: Always

Steps to Reproduce:
1. It happens once per day or two (for 2-3 months), always different circumstances
2. It happened with 1.3.1, 1.3 and 1.2.1 also (maybe 1.1--don't rember)
3.

Actual Results:  
Mozilla is shut down, details can be optionally sent back to Nescape, but all
other tabs and other Mozilla windows are frozen also, losing both their content
and their addresses (which web pages were being rendered).  Loss of several
pages that took hours to find is substantial.  Mozilla crashes more often than
Windoze 98SE; almost as bad a completely restarting with no warning.

Expected Results:  
1. Mozilla should not shut down all instances of Mozilla if one tab of one
instance performs an illegal operation; it should stop the tab in question, but
not other tabs or other Mozilla windows.  2. If Mozilla must shut down, it
should allow other tabs or at least other Mozilla windows to be viewed before
being killed--it should NOT prevent the user from even knowing which other pages
were open.  At LEAST: If the other tabs and windows simply can not be viewed,
there should be the option to save a list of all open pages in a standard
location, or on the desktop in a file such as "Mozilla_Last_Pages_Killed.txt" or
that file should simply be created automatically.

The most recent crash was during print preview.  Only use modern theme (classic
wastes screen space), with Google Toolbar.  1-3 windows of Mozilla with a total
of 6-12 tabs are typically lost, and it usually took 2-3 hours to find those
particular pages--it's a substantial loss, not the trivial task of simply
restarting Mozilla.  The time and effort to find THOSE pages again, even with
the History list, is significant (an extra hour of work)--I would rather
completely restart Windoze as long as I had the list of which pages were open
when Mozilla suddenly killed all of them.  The History list only groups by
day--can't be sorted by time opened or closed (Suggestion: enable sort History
by time closed). Windoze98SE 512MB, Norton SystemWorks used at least once a week
to clean up all Windoze debris & problems.    This has happened ~2 dozen times
in 2-3 months--only now reporting because it persists in happening, regardless
of version.   I still love Mozilla & install it on every PC I can when no one is
looking.  Mozilla's home page should have a link to Neil's "101 things the
Mozilla browser can do that IE cannot" at
http://www.xulplanet.com/ndeakin/arts/reasons.html .
for me, mozilla crashes when I test crasher bugs, and often I don´t see the
crash other users are writing about. Use a more recent mozilla, now bookmarks
are saved when you create them, so they are not lost if crashing.
Mozilla must not shut down, it simply crashes, and when it crashes, there is no
way to control the shutdown, else it wouldn´t be called crash.
Reporter:
Which nvidia grpahic driver version do you use ?

1) means that Mozilla must open one process for each window. Thios would use
many RAM and is Wontfix.
(but mailnews will use a different process in the future)
forgot my previous comment...

this is wontfix 
But there is a bug to store to current open windows and restore them on the next
Mozilla restart

*** This bug has been marked as a duplicate of 19454 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.