Closed Bug 20708 Opened 20 years ago Closed 20 years ago

Dialog appears before it has been properly initialized

Categories

(Core :: DOM: Editor, defect, P4)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: Brade, Assigned: danm.moz)

Details

With debug build from this morning on Mac, when I choose quit or close from a
menu for a composer window, I get a dialog asking me for a login and password and
with a check box.
OS: Mac System 8.5 → All
Hardware: Macintosh → All
Kin sees this on Windows so changing platform/os
Severity: normal → critical
Priority: P3 → P1
This is happening all around the application in the 19991203xx builds. This is a
severe bug as it prevents you from doing many important things such as:
- entering a password to view your mailbox
- single signon / wallet operations
- etc.
Christopher, are you seeing this on the commercial build?
I'm seeing this on the commercial builds on Linux (all three from today,
12/1/99), Mac OS, and Win32. I have not tested Mozilla builds.
Assignee: beppe → sfraser
Simon, can you check this one out?
Using today's (19991206) builds, this dialog appears only briefly (very briefly
on faster machines and Win32) before it's replaced by the correct dialog.
Status: NEW → ASSIGNED
Yes, I see this. This is almost certainly NOT my bug, but I guess I'll look into
it.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
This is now fixed for me.
I think this was another one of the side effects from Travis' checkins on Friday.
Status: RESOLVED → VERIFIED
Status: VERIFIED → REOPENED
brade: it still happens if you use the Close menu item; the password dialog

flashes up. Maybe this is a wallet dialog?
Resolution: FIXED → ---
The problem here is that the window morphs after it is made visible. This is a
known issue, bug unknown
Assignee: sfraser → danm
Status: REOPENED → NEW
Summary: quitting or close from menu causes wrong dialog to appear → Dialog appears before it has been properly initialized
Reassign to damn, since the problem is that the window has been made visible too
early.
Is this only happening in debug builds? I know the original writeup says debug,
bug CPratt mentions what sound like the daily opt builds. I'm not seeing it in
today's opt bits.
This is happening in normal (non-debug) builds. Originally (Dec 3), the dialog (I think it said Simple Title?) would stick around forever; now (Dec 6), it just appears and disappears
very quickly (on a very fast machine, it might just look like a quick flash).
Priority: P1 → P4
Target Milestone: M15
If all that happens is a quick flash, then the severity should be greatly
reduced. assigning to danm as p4 for m15
Severity: critical → normal
Reducing severity (when this originally happened, it was indeed a big problem,
but it isn't so bad now).
I can't see this in today's build. The time of initial window visibility has been 
pushed out in the time between this bug's filing and now. Anyone?
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
I don't see this anymore....Kathy reopen if you still see this...
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.