Crash [@ dosprintf] from XPCConvert::ConstructException

VERIFIED INVALID

Status

()

--
critical
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: timeless, Assigned: dbradley)

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

16 years ago
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/js/src/jsprf.c&rev=3.14&cvsroot=/cvsroot&mark=952,1100,1078
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/js/src/xpconnect/src/xpcconvert.cpp&rev=1.82&cvsroot=/cvsroot&mark=1173,1410,1243

jesus_x dropped in a replacement editor.js for me and it would seem that it
caused problems....
Incident ID 20416305
Stack Signature 	msvcrt.dll + 0x3381c (0x77c4381c) 68a73041
Product ID 	MozillaTrunk
Build ID 	2003052209
Trigger Time 	2003-05-25 00:12:56
Platform 	Win32
Operating System 	Windows NT 5.1 build 2600
Module 	msvcrt.dll
URL visited 	testing timeless's editor.js patch
User Comments 	
Trigger Reason 	Access violation
Source File Name 	
Trigger Line No. 	

Stack Trace 	

msvcrt.dll + 0x3381c (0x77c4381c)
dosprintf [c:/builds/seamonkey/mozilla/js/src/jsprf.c, line 957]
JS_vsmprintf [c:/builds/seamonkey/mozilla/js/src/jsprf.c, line 1101]
JS_smprintf [c:/builds/seamonkey/mozilla/js/src/jsprf.c, line 1081]
XPCConvert::ConstructException 
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcconvert.cpp, line 1174]
XPCConvert::JSErrorToXPCException 
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcconvert.cpp, line 1414]
XPCConvert::JSValToXPCException 
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcconvert.cpp, line 1255]
nsXPCWrappedJSClass::CheckForException 
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, 
line 824]
nsXPCWrappedJSClass::CallMethod 
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, 
line 1367]
nsXPCWrappedJS::CallMethod 
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 
429]
PrepareAndDispatch 
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp, 
line 119]
SharedStub 
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp, 
line 147]
nsEventListenerManager::HandleEventSubType 
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, 
line 1192]
nsEventListenerManager::HandleEvent 
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, 
line 1876]
GlobalWindowImpl::HandleDOMEvent 
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 819]
DocumentViewerImpl::LoadComplete 
[c:/builds/seamonkey/mozilla/content/base/src/nsDocumentViewer.cpp, line 
954]
nsDocShell::EndPageLoad 
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp, line 4334]
nsWebShell::EndPageLoad 
[c:/builds/seamonkey/mozilla/docshell/base/nsWebShell.cpp, line 881]
nsDocShell::OnStateChange 
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp, line 4268]
nsDocLoaderImpl::FireOnStateChange 
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp, line 1214]
nsDocLoaderImpl::doStopDocumentLoad 
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp, line 869]
nsDocLoaderImpl::DocLoaderIsEmpty 
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp, line 767]
nsDocLoaderImpl::OnStopRequest 
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp, line 697]
nsLoadGroup::RemoveRequest 
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsLoadGroup.cpp, line 703]
nsJARChannel::OnStopRequest 
[c:/builds/seamonkey/mozilla/netwerk/protocol/jar/src/nsJARChannel.cpp, 
line 660]
nsCOMPtr_base::assign_with_AddRef 
[c:/builds/seamonkey/mozilla/xpcom/glue/nsCOMPtr.cpp, line 71]
nsInputStreamPump::OnStateStop 
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsInputStreamPump.cpp, 
line 484]
nsInputStreamPump::OnInputStreamReady 
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsInputStreamPump.cpp, 
line 325]
nsInputStreamReadyEvent::EventHandler 
[c:/builds/seamonkey/mozilla/xpcom/io/nsStreamUtils.cpp, line 117]
PL_HandleEvent [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, 
line 660]
PL_ProcessPendingEvents 
[c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 596]
_md_EventReceiverProc 
[c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 1396]
USER32.dll + 0x4455 (0x77d44455)
USER32.dll + 0x95d5 (0x77d495d5)
nsAppShellService::Run 
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, 
line 479]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 
1284]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1650]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, 
line 1672]
WinMainCRTStartup()
kernel32.dll + 0x214c7 (0x77e814c7)

I don't really see any traces of my editor.js in this code so i can't be certain
it relates. The code looks fine, any thoughts?
(Assignee)

Comment 1

16 years ago
At the time of the crash it was processing an exception that occured in JS code,
probably in the editor.js. Most likely either the interface name or the method
name string passed in was bad. There's null checks before we get to this spot,
so they weren't null.

Is this reproduceable? If it is, can you attach the editor.js file, or e-mail it
to me.
Summary: Crash [@ dosprintf] from XPCConvert::ConstructException → Crash [@ dosprintf] from XPCConvert::ConstructException

Comment 2

16 years ago
I'm resolving this as invalid. The problem was how I conducted the test. I
unjarred comm.jar, but forgot to edit installed-chrome.txt and the others to
reflect that comm.jar would not be found, thus the crash. It's 100% reproducable
if you just do what I did.

1) Unzip comm.jar to chrome/comm/
2) rename/remove comm.jar
3) Start Mozilla

If this is somehow valid otherwise, feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 3

16 years ago
Rubber-stamp vrfy -
Status: RESOLVED → VERIFIED
Crash Signature: [@ dosprintf]
You need to log in before you can comment on or make changes to this bug.