Closed Bug 207121 Opened 18 years ago Closed 17 years ago

Event list shows wrong 'End' of allday events

Categories

(Calendar :: General, defect)

x86
Windows 98
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 232320

People

(Reporter: mttl, Assigned: mostafah)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030507

Allday events are correctly shown in the day-, week- and month-view but in the
event list, the end date is wrong. Obviously, the event list just shows the
contents of the DTEND tag which is the first day _after_ the event.

Reproducible: Always

Steps to Reproduce:
1. Create a new event and check 'This event lasts all day'. It may span only one
or several days.


Actual Results:  
The event list is showing the first day after the event for 'End' whereas the
day- week-, or month-view is correct. 

Expected Results:  
The last day of the event should be shown for 'End'. It is confusing that the
list shows a day that is _after_ the event (e.g. a one-day event is shown with
two days).
Works for me from cvs.
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → WORKSFORME
Woops, I was wrong. I see the problem now.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
*** Bug 210187 has been marked as a duplicate of this bug. ***
Another effect of the same problem
( as mentioned in Bug 210187 :
 "The calendar saves an event from 2003-06-21T00:00 to 2003-06-22T00:00.
  The consequence is that the event list says that the event lasts 2 days.")
is:
When you create a ("all") day-event in moz Calendar,
and re-import the event (in the form of of one or more events or as a whole
calendar file, in ics-format),
the one day event is imported as a two day event.
(Probably every n-day-event wil become an event for (n+1) days.)

This makes the severity of this bug far more than "trivial".
I would suggest "normal" or even "major" severity,
because of combination of the following:
a. "all day events" are an essential feature of the Calendar, especially as
there is not yet an option for "indefinite" start and end time.
b. In the current flux of frequently upcoming versions of Mozilla (and its
*birds) the possibility to export and reimport Calendars is essential.
c. The adding of one day in the duration of an event by re-inporting,
makes the Calendar unusable for clueless users.
New contact from mikep@oeone.com to mostafah@oeone.com
Filter on string OttawaMBA to get rid of these messages. 
Sorry for the spam.
Assignee: mikep → mostafah
An one-day-event is shown correctly in the event list (i.e. start and end date
is the same day (the one of the event)) when it is a recurrent event!
I studied some calendars of icalshare.com (e. g. school holidays). For me it
seems to be the same format, i. e. the last day shown in the calendar is one day
before the stored day. Or vice versa, the stored day is the last day of the
multi day event + 1. So this is perhaps the standard ical format, and mozilla is
just working an intended (fulfilling the standard). I didn't search for the
standard definition, though. It's just my conclusion. The event list shows the
stored value. But perhaps it would be  more consistent, if the last day dates
shown in the event list were the same as in the week or moth overview.
Issue of All-Day events showing as the next day on End Date


Syntax of the message, for example:

Title:
  test
Start:
  All day Tuesday, March 02, 2004
End: 
  All day Wednesday, March 03, 2004

This is obviously very misleading,  if the stored format is indeed iCal typical,
ok...just correct the display and import.
This is a dupe of Bug 232320, (actually other way around), though this was
resolved in its patch (#147722)
Marking this one dupe, since the patch is in 232320. 

*** This bug has been marked as a duplicate of 232320 ***
Status: NEW → RESOLVED
Closed: 18 years ago17 years ago
Resolution: --- → DUPLICATE
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.