Last Comment Bug 207194 - readonly checkboxes can still be modified
: readonly checkboxes can still be modified
Status: RESOLVED DUPLICATE of bug 88512
:
Product: Core
Classification: Components
Component: Layout: Form Controls (show other bugs)
: Trunk
: All All
: -- minor (vote)
: ---
Assigned To: layout.form-controls
: Prashant Desale
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-26 20:33 PDT by Berend de Boer
Modified: 2003-05-26 22:15 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Various kinds of checkboxes (668 bytes, text/plain)
2003-05-26 20:33 PDT, Berend de Boer
no flags Details
Various kinds of checkboxes (668 bytes, text/html)
2003-05-26 20:33 PDT, Berend de Boer
no flags Details

Description Berend de Boer 2003-05-26 20:33:00 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

According to the specs (html 4.01, 17.12.2):

  When set for a form control, this boolean attribute prohibits changes to
  the control.

  ...

  The following elements support the readonly attribute: INPUT and TEXTAREA.


Reproducible: Always

Steps to Reproduce:
1. Load checkbox.html
2. Click on the checkboxes.

Actual Results:  
Only disabled checkbox cannot be changed.

Expected Results:  
Readonly checkboxes should not be modifiable.

Workaround: make the checkbox disabled.

But it still violates the specs.
Comment 1 Berend de Boer 2003-05-26 20:33:31 PDT
Created attachment 124252 [details]
Various kinds of checkboxes
Comment 2 Berend de Boer 2003-05-26 20:33:41 PDT
Created attachment 124253 [details]
Various kinds of checkboxes
Comment 3 Matthias Versen [:Matti] 2003-05-26 22:12:54 PDT
.
Comment 4 Matthias Versen [:Matti] 2003-05-26 22:15:44 PDT

*** This bug has been marked as a duplicate of 88512 ***

Note You need to log in before you can comment on or make changes to this bug.