cannot hide joins/parts in chat window

RESOLVED FIXED

Status

enhancement
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: christophergrif, Assigned: bugzilla-mozilla-20000923)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-need-patch][cz-0.9.68.2][cz-0.9.76])

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425

feature request: I would like to be able to hide joins/parts in the chat window.
 In a very active room (100+ people) the joins and parts being displayed in the
chat window makes a conversation hard to follow.  mIRC calls this feature
'conference mode'.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

16 years ago
Posted patch patch v1 (obsolete) — Splinter Review

Updated

16 years ago
Attachment #125633 - Flags: review?(rginda)

Comment 2

16 years ago
Posted patch patch v2 (obsolete) — Splinter Review
This patch works with cz0.9.35.
Attachment #125633 - Attachment is obsolete: true

Updated

16 years ago
Attachment #125633 - Flags: review?(rginda)

Updated

16 years ago
Whiteboard: cz-patch
(Assignee)

Comment 3

16 years ago
I've got a basic version working, hiding JOIN, PART and QUIT messages. Is there
anything else for a "conference mode"? Hide nick-changes, perhaps?
Assignee: rginda → silver
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

15 years ago
*** Bug 247512 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

15 years ago
If anyone wants to do this before I resurect my patch, you need to put the
following into userContent.css:

.msg[msg-type="JOIN"], .msg[msg-type="PART"], .msg[msg-type="QUIT"] { display:
none; }

If you only want to affect a single channel, use this:

.msg[msg-type="JOIN"][msg-dest="#channel"],
.msg[msg-type="PART"][msg-dest="#channel"],
.msg[msg-type="QUIT"][msg-dest="#channel"] { display: none; }

...replacing #channel with the right thing. :)
Product: Core → Other Applications
(Assignee)

Comment 6

14 years ago
This patch adds an automatic conference mode (where JOIN, PART, NICK and QUIT
messages are hidden), which uses a preference to determin the user count needed
to trigger it. Default is 50, and to prevent "flapping" it must go at least 10
above or below before it changes. You can force it on or off globally, per
network or per channel by setting the limit to 0 (off/current behaviour) or 1
(on).
Attachment #131739 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #182178 - Flags: review?(rginda)
(Assignee)

Updated

14 years ago
Whiteboard: cz-patch → [cz-patch][0.9.68.2]
(Assignee)

Updated

14 years ago
Whiteboard: [cz-patch][0.9.68.2] → [cz-patch][cz-0.9.68.2]

Comment 7

14 years ago
Comment on attachment 182178 [details] [diff] [review]
[checked in] Add conference mode

Nit:

>@@ -2155,14 +2202,18 @@ function my_cnick (e)
>                              "NICK", "ME!", e.user, this);
>         }
>         this.parent.parent.updateHeader();
>     }
>     else
>     {
>-        this.display(getMsg(MSG_NEWNICK_NOTYOU, [e.oldNick, e.user.unicodeName]),
>-                     "NICK", e.user, this);
>+        if (!this.prefs["conference.enabled"])
>+        {
>+            this.display(getMsg(MSG_NEWNICK_NOTYOU, [e.oldNick,
>+                                                     e.user.unicodeName]),
>+                         "NICK", e.user, this);
>+        }
>     }
> 
>     e.user.updateGraphResource();
>     //this.updateUsers([e.user]);
>     /* updateUsers isn't clever enough (currently) to handle a nick change, so
>      * we fake the user leaving (with the old nick) and coming back (with the

Is there any reason you can't use 'else if' in one block here? Would also save
you from using another line for the display call.
Attachment #182178 - Flags: review+
(Assignee)

Updated

14 years ago
Blocks: 299458
(Assignee)

Comment 8

14 years ago
No reason at all; good catch!
(Assignee)

Comment 9

14 years ago
One thing that is coming up A LOT in #chatzilla is "where are the joins/parts?"
and even weirder stuff like "can ChatZilla display joins/parts?".

For 0.9.68.6 I've made sure the message for when it turns on explains what it is
hiding, and also made it show the explanation EVERY time you join a channel
where it is in effect (since people are great at missing it when it first happens).

rginda, if you could review the existing patch (attachment 182178 [details] [diff] [review]), the heavy
lifting can be landed and the updates I have for 0.9.68.6 can be done as their
own much smaller patch.

Comment 10

14 years ago
Comment on attachment 182178 [details] [diff] [review]
[checked in] Add conference mode

I think 50 is way to low of a default value.  I'd rather see something more
like 150, myself.  Other than that it looks good to me.  r=rginda.
(Assignee)

Updated

14 years ago
Attachment #182178 - Attachment description: Add conference mode → [checked in] Add conference mode
Attachment #182178 - Attachment is obsolete: true
(Assignee)

Comment 11

14 years ago
Updating whiteboard; this bug needs the patch for always notifying users of the conference state (if it is on) when joining channels, and some other minor tweaks.
Whiteboard: [cz-patch][cz-0.9.68.2] → [cz-need-patch][cz-0.9.68.2]

Updated

13 years ago
No longer blocks: 299458
(Assignee)

Comment 12

13 years ago
Comment on attachment 182178 [details] [diff] [review]
[checked in] Add conference mode

Clearing r? since patch has already been checked in and was given r beforehand.
Attachment #182178 - Flags: review?(rginda)
(Assignee)

Comment 13

13 years ago
Attachment #231389 - Flags: review?(samuel)

Updated

13 years ago
Attachment #231389 - Flags: review?(samuel) → review+
(Assignee)

Comment 14

13 years ago
Last patch checked in --> FIXED (completely).
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Whiteboard: [cz-need-patch][cz-0.9.68.2] → [cz-need-patch][cz-0.9.68.2][cz-0.9.76]
You need to log in before you can comment on or make changes to this bug.