When I click on the "Print this Page" link, Mozilla stops responding

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
--
critical
RESOLVED WORKSFORME
15 years ago
5 years ago

People

(Reporter: Joshua Wilner, Unassigned)

Tracking

({crash, hang})

Trunk
x86
All
crash, hang
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030522
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030522

When I click on the "Print this Page" link, Mozilla stops responding, and my
system freezes; I have run the error several times and find it difficult if not
impossible to use task manager to close Mozilla. Usually just have to power
down.  A Geoshell status monitor I use shows 100% usage of the CPU after the
error occurs. I think the link starts a Java script. Sorry if this has already
been reported. I looked over the list but am not adept enough to recognize which
of the reported bugs might correspond to the problem I've encountered. 

Reproducible: Always

Steps to Reproduce:
1.go to url listed
2. click on print this page
3.

Actual Results:  
Mozilla stops responding; system freezes

Expected Results:  
print the page

I use Geoshell as my shell. Otherwise, standard XP configuration.
wfm with win2k build 20030526..

Comment 2

15 years ago
happens for me too 2003052508 on Win2k, Print Preview.
Keywords: hang

Comment 3

14 years ago
Confirming bug, 2003-11-10-05 trunk Linux.  I get a crash.
Status: UNCONFIRMED → NEW
Depends on: 185357
Ever confirmed: true
Keywords: crash
OS: Windows XP → All

Comment 4

14 years ago
Attempted to reproduce on linux using cvs build 20031230, but wfm. Can anyone
reproduce this with a recent copy of mozilla? If it crashes, could you supply a
stack trace?

Comment 5

14 years ago
This bug worksforme with Windows Seamonkey builds 2004020909
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 6

5 years ago
I am using ff 22.0.
I have just performed a scan using my wifi-enabled hp officejet 8500 pro wireless. and adobe acrobat 9 pro. I have version 14.301.0 printer software installed, if that makes any difference.
it is possible the software has somehow disconnected itself from the printer network-wise. 
then I printed some receipts from grc.com.
then I think my mother did some copies on the printer using the copy button.
this is usually not a problem.
then I printed this page http://www.fact-reviews.com/info/Spinrite.aspx
after rebooting. but every time I do, it ff hangs and the cancel button is grayed out. I can try it again after I finish this post. it is possible the printer software has gotten into a strange state. I power-cycled the printer also, this usually allows it to reconnect. but I suspect from about 6 other similar bug reports that this is an ff bug of some sort maybe.

I don't know if it's some weird state my prrinter is in, or what, but I doubt that since I had just rebooted, and my printer has been working fine. my wifi analyzer shows that nobody else is on my channel, so it's not a channel conflict.

so it looks to me like it's either a new 22.0 bug, so it looks like a problem with this particular web page causing an ff print hang.
you may want to analyze this page to see what's on it that is causing the problem.
my platform is: win7ult64 ff22.0 i7-3970x 64GiB RAM 2x4TB hd's, 1xSSD which is not being used.
You need to log in before you can comment on or make changes to this bug.