All users were logged out of Bugzilla on October 13th, 2018

Junk status flag disappears in junk mail moved to junk folder

RESOLVED DUPLICATE of bug 191750

Status

RESOLVED DUPLICATE of bug 191750
16 years ago
10 years ago

People

(Reporter: tri, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

I've spotted this behavior in account using Double Precision's
Couried-IMAP server.  There the Junk-folder is a subfolder of
Inbox rather than a folder in imap server root.  Junk flag appears
to new spam messages and then they are correctly moved to the Junk
folder, but when visiting the Junk folder, the junk status is gone.
If junk status is manually added it seems to stay there ok.

In my other account with Dovecot IMAP-server, junk status stays
on fine.

Reproducible: Always

Steps to Reproduce:
1. Configure junk filter (move to other -> inbox/junk)
2. Get some junk filtered (and moved to junk)
3. Visit junk folder

Actual Results:  
I see junk folder with new messages that have no junk flag on.

Expected Results:  
I see junk folder with new messages that have junk flag on.


With 1.3 this behavior did not appear.

Updated

16 years ago
Summary: Junk status flag disappears in junk mail moved to junk folder → Junk status flag disappears in junk mail moved to junk folder

Comment 1

16 years ago
Same problem? When a message auto-flagged as junk is auto-moved to the junk
folder on the IMAP server, the junk flag disappears.

Using Debian Linux (testing), talking to an Exchange 2000 server.

Using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529

Comment 2

16 years ago
Same thing occurs with me. This seems to have stopped working in the last
week or so.

Comment 3

16 years ago
I get this on 1.4rc2. When option move to junk folder when marked as junk is
selected.

1. flags as junk 
2. moves to folder
3. flag is lost

This happens with labels as well - related?


Comment 4

15 years ago
Happens for me too, using Mozilla Thunderbird 20030829 build

Comment 5

15 years ago
*** Bug 215808 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
*** Bug 196905 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
this bug is a duplicate of bug 191750

Comment 8

15 years ago

*** This bug has been marked as a duplicate of 191750 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.