If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

HTML entities don't work correctly in CSS content rule.

RESOLVED INVALID

Status

()

Core
CSS Parsing and Computation
RESOLVED INVALID
15 years ago
12 years ago

People

(Reporter: Jan Suchal, Assigned: dbaron)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

content: " ";

in 
q:before { content: " "; }

and the browser prints out the string   not the non-breaking space

Reproducible: Always

Steps to Reproduce:
1. Make any CSS rule like p:after { content: "[ ]"; }
2.
3.



Expected Results:  
Mozilla should replace it with valid html entity representation.

Comment 1

15 years ago
Reading the CSS2 and even CSS3 specs on content, I believe that content isn't
supposed to do that.  You're simply giving it a text string to output (generally
speaking).  I suspect this bug is invalid.

Comment 2

15 years ago
See bug 204324 comment 1.  Mozilla is not supposed to replace &nbsp and it
should be returning the actual string.  So this is invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
See http://www.w3.org/TR/CSS21/syndata.html#q4 for documentation of CSS
character escapes.

Comment 4

14 years ago
*** Bug 215770 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
*** Bug 281262 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
*** Bug 292192 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.