right click on digital signature image displays context menu after certificate dialog is dismissed

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
minor
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: David Bradley, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2) Gecko/20030208 Netscape/7.02
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2) Gecko/20030208 Netscape/7.02

Summary pretty much says it all, the context menu is displayed when right
clicking on the digital certificate, AFTER the certficate dialog is dismissed.

Reproducible: Always

Steps to Reproduce:
1. View a message with a digital certificate
2. Right-click on the certificate image on the message
3. Dismiss the certificate dialog


Actual Results:  
Context menu is displayed, apparently for whatever was was under the cursor at
the time the dialog is dismissed.

Expected Results:  
Either right clicking on the digital certificate does nothing, or right clicking
brings up a context menu (not sure what should be in it).

Comment 1

14 years ago
I can confirm this with Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6)
Gecko/20040113 and with Thunderbird 0.5 (20040207) on Windows XP Professional.
That this bug is happening may not always be obvious. To ensure that it will be
visible, the mouse cursor must be over a right-clickable object when you dismiss
the dialog. It's OK to use the mouse to click the OK button; just make sure the
part of the program/message window under the dialog's OK button produces a
context menu when right-clicked. If your mouse cursor is over a
non-right-clickable object or is outside the borders of the window displaying
the message that has the certificate when the dialog is dismissed (can be done
by moving the dialog to strategically position the OK button, or by dismissing
the dialog via the keyboard after moving the mouse cursor) you will not see the
context menu. Sorry that's so wordy. I tried to make it accurate.

Here are two more detailed methods to reproduce this bug, based on the
reporter's steps. The first is the easiest way to reproduce this bug, the second
is the way this bug is most likely to happen accidentally.

first method:
1. View a message with a digital certificate
2. Right-click the certificate image for the message
3. Move the mouse cursor over a part of the window that will produce a context
menu when right-clicked
4. Press the Esc key to dismiss the dialog
5. Observe the appearance of a context menu as though you had just right-clicked
where your mouse cursor is

second method:
1. View a message with a digital certificate
2. Observe the layout of the window
3. Right-click the certificate image for the message
4. Verify that the dialog window's OK button is over a part of the
message-displaying window that will produce a context menu when right clicked.
5. Click the OK button to dismiss the dialog
6. Observe the appearance of a context menu as though you had just right-clicked
where your mouse cursor is

You may substitute the [X] close window control for the OK button in the second
method.

I like the reporter's suggested expected result of a right-click on the digital
certificate image doing nothing.
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
Assignee: mail → nobody
QA Contact: esther → message-display

Comment 2

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 3

9 years ago
Right-clicking on the Yellow Pen image does nothing in SM2 anymore. WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.