Closed Bug 207531 Opened 17 years ago Closed 12 years ago

Allow editor to edit xhtml files (as html)

Categories

(Core :: Editor, defect, minor)

defect
Not set
minor

Tracking

()

RESOLVED FIXED

People

(Reporter: timeless, Assigned: timeless)

References

(Depends on 1 open bug, )

Details

Attachments

(1 file)

This is not a panacea, it won't switch composer into an xml editing mode, nor
will it prevent composer from using htmlisms, nor will it enable composer to
save as xml/xhtml.

all i want is to be able to load an xhtml file, edit it (as html), and save as
html (or text). and that's all my patch does.
Attached patch nothing fancySplinter Review
Attachment #124477 - Flags: superreview?(sfraser)
Attachment #124477 - Flags: review?(brade)
Will composer make appropriate noises about switching the DOCTYPE of your
document under you? I doubt it.
OS: Windows 2000 → All
Hardware: PC → All
see bug 78128 which has another patch.
Depends on: 78128
Working on it for Nvu.
Product: Browser → Seamonkey
Comment on attachment 124477 [details] [diff] [review]
nothing fancy

This patch seems ok to me but I'm concerned that it may conflict with what
Daniel has done.  Passing review to him.

Timeless--does the doctype get altered when this is opened/saved in Composer or
is it left untouched?
Attachment #124477 - Flags: review?(brade) → review?(daniel)
Note there's a similar mimetype check in the patch for bug 133827.  (You need 
this to get Copy/Paste to work.)  That patch is now part of the trunk.
timeless, I am a bit reluctant to give you an r= on this patch because it's
conflicting with my own changes. The basis of your code addition is absolutely
right, don't misunderstand me. But I'm doing more than that to allow to publish
with the correct mimetype, trigger the xml parser and not the html one, and so on.
Comment on attachment 124477 [details] [diff] [review]
nothing fancy

Since Nvu 1.0 codebase is schedule to die and since this is needed for Mozilla Composer, r=daniel@glazman.org

Please note it _may_ haver some side effect on Composer in Seamonkey : the document may load but since some commands check the doctype of the document, they could fail.
Attachment #124477 - Flags: review?(daniel) → review+
Comment on attachment 124477 [details] [diff] [review]
nothing fancy

This patch fixes bug 401990 (which is basically a dupe). Rob, can you sr+ this?
Attachment #124477 - Flags: superreview?(sfraser_bugs) → superreview?(roc)
Duplicate of this bug: 320092
Duplicate of this bug: 401990
Comment on attachment 124477 [details] [diff] [review]
nothing fancy

This can land because it's basically a dup of a blocker.
Attachment #124477 - Flags: superreview?(roc) → superreview+
Attachment #124477 - Flags: approval1.9?
Comment on attachment 124477 [details] [diff] [review]
nothing fancy

a=mconnor on behalf of drivers
Attachment #124477 - Flags: approval1.9? → approval1.9+
timeless landed this at 2007-11-13 14:08

mozilla/editor/composer/src/nsEditingSession.cpp 	1.56
Status: NEW → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
No longer depends on: 403724
Depends on: 403724
Depends on: 403828
No longer depends on: 403828
Depends on: 403965
Blocks: 320092
Component: Composer → Editor
Product: Mozilla Application Suite → Core
QA Contact: chrispetersen → editor
Depends on: 431184
Depends on: 432025
You need to log in before you can comment on or make changes to this bug.