Attaches additionally the extension of some serverside downloadscripts

VERIFIED DUPLICATE of bug 65827

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 65827
15 years ago
10 years ago

People

(Reporter: andreas schipplock, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

I think there is some problem in the http-implementation, because I tried to
find out why Firebird does not interpret the following correctly. I send a
header within a serverside script with the following content:
Content-Disposition: attachment; filename="fname.ext"
So, if Firebird starts to show the client-user the download-window, Firebird has
decided to choose this filename "fname.ext.php", but I have specified the
filename and in the protocol specification it´s also mentioned as above.
(http://www.w3.org/Protocols/rfc2616/rfc2616-sec19.html#sec19.5.1). For me it
seems that Firebird catches the extension of the script and attaches it
automatically, but this seems not correct.



Reproducible: Always

Steps to Reproduce:
Ok, let´s reproduce it in some short steps:
1.) set up any apache server with php 4.x ( I think you have already done )
2.) catch any file and test the following script:

<?php
	header("Content-type: application/gz");

	header("Content-Disposition: attachment; filename=\"test.gz\"");

    $data = implode("", file("fonts/blasphem.ttf"));
    $gzdata = gzencode($data, 9);
    $fp = fopen("fonts/blasphem.ttf.gz", "w");
    fwrite($fp, $gzdata);
    fclose($fp);
    
	readfile('fonts/blasphem.ttf.gz');
?>

3. Start the script within Firebird and see. You will see that you can download
the file with the extra extension.
Actual Results:  
I have a downloaded file with two extensions :)

Expected Results:  
Just leave the filename as I have specified.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 65827 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
VERIFIED
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.