page too wide in mozilla requiring use of horizontal scrollbar usage, IE 6.0 wraps text without scroll bar necessity

RESOLVED DUPLICATE of bug 95067

Status

()

defect
RESOLVED DUPLICATE of bug 95067
16 years ago
16 years ago

People

(Reporter: erik_habbinga, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030522 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030522 Mozilla Firebird/0.6

The journal at neilgaiman.com, when viewed with Mozilla + Mozilla Firebird
doesn't  wrap the text the same way as Internet Explorer 6.0.  Viewed with
Mozilla, the text in the journal entry
http://www.neilgaiman.com/journal_archives/2003_05_01_archive.asp#200358352
wraps after the phrase "on the fax they sent", which makes the entire sentence
viewable only when my mozilla window is about 1024 pixels wide.  IE wraps after
the phrase "pointing out that he put", which allows me to have a IE window about
640 pixels wide without a horizontal scroll bar.

Can I set up Mozilla to wrap these pages earlier?  Is this a problem in the
neilgaiman html code?

Reproducible: Always

Steps to Reproduce:
1. load the neilgaiman.com journal page in both IE and Mozilla
2. change window size of each browser window until the horizontal scroll bar
disappears
3. note that the mozilla browser window is much bigger than the IE window.

Actual Results:  
the mozilla browser window almost takes up my entire screen width (1280 x 1024)
to view the neilgaiman.com journal webpage without a horizontal scroll bar.  The
IE 6.0 browser window is about half the screen width.

Expected Results:  
wrap the text at the same place IE does?  wrap the text to fit the size of my
browser window?
worksforme 2003-05-28-08 trunk Linux
I'm seeing what the reporter sees.
(I'm on a dial-up connection, it seems that with these sort of problems, it does
make a difference, people on high speed connections tend not to see the problem.)

Unlike the other bugs I've seen on similar issues, this problem does not resolve
itself on reload.  The page persists in loading too wide.
I'm seeing what the reporter sees.
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030529
Win98, 800x600, Mozilla BuildID 2003052908, ISDN.
Page Inspector shows: The page is rendered in Quirks Mode, size unknown.
Maybe not using quirks mode should improve the situation?
Here's an answer posted to the neilgaiman journal.  Not breaking hyphenated 
lines appears to be the culprit.

> Don't know about the FAQ's margins, but the Journal proper was
demarginated
> by the line about
>
"so-bad-it's-well-not-good-but-everyone-will-at-least-remember-this-show-as-
> opposed-to-most-other-Eurovision-entries"

Mozilla, Netscape and other Mozilla-based browsers don't break hyphenated
"phrases". Internet Explorer doesn't have this problem, and I suspect Opera
is fine too (I don't have it installed ATM), hence some people getting it
but not others. Solution: remove hyphens, or wait for the offending journal
entry to disappear in the archives.
Confirmed:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030604
Text definately wider in Mozilla than in IE6.

*** This bug has been marked as a duplicate of 95067 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.