Popup "compact all local folders?" blocks loading pages in Navigator

RESOLVED DUPLICATE of bug 74331

Status

defect
--
critical
RESOLVED DUPLICATE of bug 74331
16 years ago
15 years ago

People

(Reporter: renelanz, Assigned: sspitzer)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030510
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030510

I started Navigator, opened a few tabs and started mailnews which I minimized
when the window appeared. Because of this I didn't realize mailnews poped up a
dialog box asking me if I want to compact all local folders. I just realized,
that the tab contents in the navigator where just partially loaded from cache
rather than completet through the internet connection. Even reload all tabs
didn't fetch any new data from the connection. So I maximized mailnews and saw
the nice dialog box which I confirmed. After that, data got fetched and
everything was fine again...

So my question: If such a dialog box blocks data fetching, why is this pop up
hidden if mailnews is minimized? Or, should it really be blocking?? 

Reproducible: Didn't try

Steps to Reproduce:
1. Start Navigator, open many tabs (best is a bookmarked set)
2. Start Mailnews which tries to compact local folders and minimize window
3. Switch back to Navigator and watch, if content in tabs is being loaded
(beware of cached contents...)

Actual Results:  
Data which is not in the cache will not be fetched from the internet as the
popup "Do you want to compact all local folders?" blocks data transfer

Expected Results:  
UI should not be blocking or always visible even if mailnews is minimized

Comment 1

16 years ago
we should probably not be allowed to put up this popup if we're minimized. This
sounds like a toolkit issue.

Comment 2

16 years ago
WFM Gentoo (KDE 3.1) Mozilla 1.4b
I had that dialog open, and I was able to interact with the pages or load new ones.

Comment 3

16 years ago
Could this be a dupe of bug 74331?

Comment 4

16 years ago
yeah, this looks like a dup, except for the minimize part. But if that bug was
fixed, this wouldn't be a problem...

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 74331 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.