Reproduce some of Internet Explorer's features in the "Add Bookmark" dialogue

VERIFIED DUPLICATE of bug 181033

Status

()

Firefox
Bookmarks & History
--
enhancement
VERIFIED DUPLICATE of bug 181033
15 years ago
12 years ago

People

(Reporter: Kevin Ar18, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

The current "Add Bookmark" dialogue that comes up when you click on
Bookmarks->Add to Bookmarks lacks a number of useability features.

First the proposals:
SUMMARY: These suggestions are based on the Internet Explorer system which seems
to be quite useful in most instances.
1) Improve the appearance of the "Add Bookmark" dialogue with an icon for the
current site.  Graphics remove the raw and unfinished feel of a program.
2) Move the OK and Cancel buttons to the side so that we can add a "Create in>>"
button.  The "Create in>>" button would reveal the customization features
necessary for users who want to organize and place their new bookmark in just
the right place.
3) Change the "Create in" window to include the icons and a graphicical
representation of the Bookmark folder structure. The "Create in>>" button would
reveal this section.  This section would be necessary for Bug 181033 to be most
effective.
4) Bug 181033 -- Add a New Folder... button.  This is only revealed when the
"Create in>>" button has been pressed.
5) Phoenix should remember which view the user last used.  For example, was
"Create in>>" open or closed.

The reasoning for this layout is as follows.
1) The current design conveys a raw and unfinished feel -- this is not something
you want a product to convey.  The addition of the graphics does wonders to
change this impression.  For further details see Bug ?????.
2) The current design does not provide adequate methods for the user to put
their bookmarks just where they want it.  This is because of the missing "New
Folder" button.  For further discussion see Bug 181033.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

15 years ago
Created attachment 124607 [details]
Example of Create in>> (non-collapsed)
(Reporter)

Comment 2

15 years ago
Created attachment 124608 [details]
Example of Create in<< (collapsed)
(Reporter)

Comment 3

15 years ago
Created attachment 124609 [details]
Outline of proposals 1-4

This bug shows where proposals 1-4 are located.
I could go for some of this, like the new folder option, as long as existing
functionality isn't comprised (like bookmark all open tabs).

Pierre, your call on this.

--> NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor

Comment 6

15 years ago
Either bug 181033 is a dupe of this or vice versa. If you're going to argue
about the best way to do the dialog, I'd recommend doing it in mozillazine.

*** This bug has been marked as a duplicate of 181033 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 8

15 years ago
Although Bug 181033 deals with the "New Folder" feature, this proposal actually
invovles other parts, including a tree view and arrangment of the dialogue
itself.  Bug 181033 does try to find a suitable way to arrange the dialogue,
however.

Below is a more detailed (and thorough) overview of what this feature would
include.  It is all a carry over from Internet Explorer.
I will be referring to "Proposals #1 - #4"  You can see a picture of these
proposals in Attachment 124609 [details].


Proposals #2 and #3 -- (Tree View)
As it stands now, Mozilla's method of adding bookmarks is much more tedious than
it needs to be.  When adding a bookmark, Phoenix only shows one line and not the
directory structure like in Internet Explorer.  By showing only one line, it
makes it much more dificult for the user to figure out where they are placing
their bookmark.  The only way for the user to find out their current location in
the directory structure is to click on the drop down list (an added tedious
process) and look at where they are at.  For users who organize bookmarks, the
need for a tree view is a must.
Thus, this proposal includes the following suggestions:
1. Continue with Mozilla's one line method, however include some kind of button
(like "Create In>>" in IE) to expand the dialogue and show a tree view [see
Attachment 124607 [details]].  This is proposal #2.
2. In the expanded dialogue, include a tree view of the folder structure like in
IE  [see Attachment 124609 [details]].
3. Mozilla should remember the last used view: normal or expanded.  The next
time the Add Bookmark dialogue is opened, it would default to the last used view.
4. When in tree view, the "Create In>>" button would change to "Create In<<"
like in IE (that is assuming we use this naming convention from IE).  Clicking
on this button would return you back to the single line view.  [Compare
Attachment 124607 [details] with Attachment 124608 [details]]
5. For looks (and useability) the tree view should have folder icons before the
names to indicate folders.  It should also, include the dotted-lines that
connect directories.  Plus/minus signs would also be needed for expanding
directories that contain subdirectories (except for the main "Bookmarks" directory).

Proposal #4 -- (New Folder button)
Bug 181033 deals with the issue of adding a "New Folder" button to the menu. 
The need for this feature is discussed in bug 181033.  To basically sum things
up, this feature offers a quick way for individuals to organize their bookmarks;
using the "manage bookmarks" feature involves a more tedious process.
One of the areas that needs clarification is how to implement this feature into
the "Add Bookmark" dialogue.  In keeping with the suggestion of this report, one
method is to go with Internet Explorer's solution.  Include a "New Folder..."
button in the "Add Bookmark" dialogue.
Some notes about this suggestion:
1. The "New Folder..." button would only be visible in the expanded view where
the tree structure is seen [see Attachment 124607 [details]].
2. Using the tree view, one highlights, the folder they plan on adding the New
Folder to.  Upon clicking the "New Folder..." button, a new window opens where
the user simply adds the name of the new folder.  After closing that dialogue
the new folder appears in the proper location and is now the one that is
highlighted.
3. NOTE: the three periods should be included at the end of the name "New
Folder..." (supposing we go with the IE name) or whatever name is chosen.  The
reason being that the three dots are a standard convention to indicate a new
window or dialogue will open.

Proposal #1 -- (Icon)
This is something purely optional for Mozilla.  To spruce up the interface to
the dialogue, Internet Explorer fills in the leftover space at the top with an
icon.  This makes the dialogue more appealing as well.  Mozilla could optionally
do the same in the space using it's default Bookmark's icon or using the current
Favicon for the site being bookmarked.
mass verification of dupes
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.