Browser crashes if you enter only // at the url bar

RESOLVED DUPLICATE of bug 185663

Status

SeaMonkey
Location Bar
--
major
RESOLVED DUPLICATE of bug 185663
15 years ago
10 years ago

People

(Reporter: H. Ebelt, Assigned: Joe Hewitt (gone))

Tracking

({hang})

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.4) Gecko/20030529

Simply enter // in the URL bar and hit enter. The bug might work with every
browser since 1.2 (if i remember correctly)

Reproducible: Always

Steps to Reproduce:
1. Enter //
2. Hit Return


Actual Results:  
The browser crashes.

Expected Results:  
Nothing, because this is an invalid url (isn't it ?)

Comment 1

15 years ago
Verified 2003053008 PC/WinXP, though I experienced a hang, and not a crash. Also
no Talkback generated.

Reporter, if you are actually crashing, do you have a Talkback ID?
Severity: trivial → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: hang

Comment 2

15 years ago
Got the same problem but the browser doesn't crash, it hangs and uses 100% CPU time.

Comment 3

15 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529

confirm hang, if // entered manually into the location bar

wfm, if I click on the test URL above, gives: 
Alert: The URL is not valid and cannot be loaded.

If I hover over the test URL link above, I see http:/// in the status bar.
(Reporter)

Comment 4

15 years ago
sorry for the circumstances. i meant the browser hangs! it only works entering
it manually ... on a website the link // will be rewritten to http:///

Comment 5

15 years ago
Dupe of bug 185663?

Comment 6

15 years ago
Yes, especially after reading http://bugzilla.mozilla.org/show_bug.cgi?id=185663#c6

*** This bug has been marked as a duplicate of 185663 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.