psychotekk.de - the target attribute in the form element is ignored

RESOLVED FIXED

Status

Tech Evangelism Graveyard
German
RESOLVED FIXED
14 years ago
2 years ago

People

(Reporter: PsychoTekk, Unassigned)

Tracking

Details

(Whiteboard: [bug248549notfixed], URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030514 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030514 Mozilla Firebird/0.6

the menu frame of www.psychotekk.de contains a form that is targeted to the main
frame. when submitting mozilla firebird does not show the page in the mainframe
but seems to do nothing. only when using www.psychotekk.de/menu.htm directly,
the page is opened in a new window.

Reproducible: Always

Steps to Reproduce:
1.enter any username into the form
2.submit
Actual Results:  
the request is submitted (and the form is reset by onSubmit="history.go()" as
intended)

Expected Results:  
the request should be submitted and the content displayed in the targeted main frame

according to the w3c standarts the target attribute is appropriate for form
elements (although not listed on the form page
http://www.w3.org/TR/REC-html40/interact/forms.html directly) and validates
(http://validator.w3.org/check?uri=www.psychotekk.de%2Fmenu.htm)

Comment 1

14 years ago
Using Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4b) Gecko/20030601 Mozilla
Firebird/0.6 I can confirm the following:

- using the given URI and entering any username and pressing Login the page 
reloads but nothing else happens
- using the direct URI to the menu the error page "you do not have permission to
perform this action" shows up after entering any username and pressing Login

Nevertheless this behaviour occurs also when using SeaMonkey Gecko/20030601, so 
if at all this is probably a Browser issue and should be filed accordingly. I 
had a quick look in related Browser bugs but didn't found a duplicate one but 
since there are many bug reports which may be related someone else should do an 
additional search.

Comment 2

14 years ago
Well, after some additional searches for possible dupes I didn't found a related
SeaMonkey bug 

=> reassigning to "Browser / Layout: Form Controls" for further investigation
Component: General → Layout: Form Controls
Product: Phoenix → Browser
Version: unspecified → Trunk

Comment 3

14 years ago
reassigning owner & QA contact
Assignee: blaker → form
QA Contact: asa → desale

Comment 4

14 years ago
The form tag has the attribute
   onSubmit="history.go()"
and that causes the frame to be reloaded before the form is submitted. (Seems
that Mozilla interprets the somewhat obscure history.go() as history.go(0).)

I'm not sure if there is an official rule how browsers are supposed to handle
situations like this, where onsubmit changes the location of the current window
but the default reaction to the submission event is not suppressed (by returning
false): Should the form be submitted or not? If there is an official rule then
Mozilla breaks it because it really behaves differently depending on whether the
page is in the frameset or not.

(BTW, I'm seeing this with Mozilla 1.5 (20030929) on Linux/PPC, so if it's
really a bug then it's All/All, not PC/Win2000.)
This has nothing to do with form controls... but in any case, our behavior is
now completely consistent -- frameset or no frameset, reloading that page via
history.go() prevents the form submission over here, as it should.

Over to evang.
Assignee: form → german
Status: UNCONFIRMED → NEW
Component: Layout: Form Controls → German
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: desale → german
Version: Trunk → unspecified

Comment 6

13 years ago
[bug248549notfixed]

Updated

13 years ago
Summary: the target attribute in the form element is ignored → psychotekk.de - the target attribute in the form element is ignored
Whiteboard: [bug248549notfixed]
owned by domain grabber
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.