No correct encoding in export, please use UTF-8 or base64 encoding

RESOLVED DUPLICATE of bug 126266

Status

()

Bugzilla
Bug Import/Export & Moving
--
major
RESOLVED DUPLICATE of bug 126266
15 years ago
6 years ago

People

(Reporter: Frank Mau, Assigned: justdave)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Jakarta HTTP Client/2.0.0a1
Build Identifier: 

When exporting some issues using http://bugzilla.mozilla.org/xml.cgi?id=ISSUE_ID
I got sax parser errors, cause the encoding is wrong/not set correctly. E.g. for
issue ids:
88732
org.xml.sax.SAXParseException: Character conversion error: "Unconvertible UTF-8
character beginning with 0xb4" (line number may be too low).

88779
org.xml.sax.SAXParseException: Character conversion error: "Malformed UTF-8 char
 -- is an XML encoding declaration missing?" (line number may be too low).

There are many more issues. What about using a modified xml export used by
gnome.org bugzilla. They convert there strings by base64 and it works well?!

Reproducible: Always

Steps to Reproduce:
1.
2.
3.




I need these import for a better Mozilla project integration inside Sun
Microsystems. If you need further information please send me an email.

Comment 1

15 years ago
So you were the person downloading the entire db. next time please ask first.
Group: webtools-security
marking duplicate of bug 126266 per bug 105960 comment 13 through 15.

For future reference, due to the amount of load it typically creates,
mozilla.org routinely blocks the IP addresses of sites using bots to collect
data off of bugzilla.mozilla.org.  It's an unfortunate but necessary measure
since it's running on ancient hardware and we need to keep it available for
those who are using it to manage bugs.

5 IPs in your class B netblock and 1 outside it, which I'm assuming is also
yours since the requests seemed to be coordinated, were banned this last weekend
for running bots.  A 6th in your netblock was being used this weekend but had
already been blocked a few months ago for similar behavior.

If you have a legitimate need for this data, please file a bug in the
mozilla.org product and ask for it.  We have other ways to get it to you that
won't tax the server quite so much.

*** This bug has been marked as a duplicate of 126266 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.