Closed Bug 207993 Opened 19 years ago Closed 19 years ago

Focus is shifted to URL's loading in background tabs.

Categories

(SeaMonkey :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 124750

People

(Reporter: mike, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030529

If a URL containing a form is opened in a background tab, the cursor focus is
incorrectly shifted to fields on the background tab rather than staying on the
tab in the foreground. Focus events should not be fired to set focus to a form
field that is not in the foreground.

Reproducible: Always

Steps to Reproduce:
1. Open a tab with a form in the foreground
2. Open another tab with a form in the background. Put a setFocus event in onLoad
3. Enter text into form field of forground form
4. Continue entering text as background tab fully loads

Actual Results:  
Cursor shifted from field on foreground tab to field on background tab.

Expected Results:  
Not change focus. Leave focus at field on foreground tab.

May be related to bug 167979
this bug and bug 167979 looks like bug 124750

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.