Some Unicode text is not displaying in the requested font face

RESOLVED FIXED

Status

()

RESOLVED FIXED
16 years ago
12 years ago

People

(Reporter: bugmail, Unassigned)

Tracking

({intl, platform-parity, testcase})

Trunk
PowerPC
Mac OS X
intl, platform-parity, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
FizzillaMach/2003-05-29-08-trunk no longer displays some font glyphs such as
horizontal ellipses (…) in fonts such as TITUS Cyberbit Basic
(<http://titus.fkidg1.uni-frankfurt.de/unicode/tituut.asp>) under Mac OS X 10.2.6.

Also fails using Mozilla 1.3, which is what leads me to believe this problem may
only occur under Mac OS X 10.2.6.

The testcase works in Safari and IE.
(Reporter)

Updated

16 years ago
Keywords: testcase
Summary: Some font glyphs not being displayed under Mac OS X 10.2.6 → Some font glyphs are not being displayed under Mac OS X 10.2.6
(Reporter)

Comment 1

16 years ago
Created attachment 124773 [details]
HTML testcase
(Reporter)

Comment 2

16 years ago
Created attachment 124774 [details]
Testcase attachment 124773 [details] as displayed by FizzillaMach/2003-05-29-08-trunk
(Reporter)

Updated

15 years ago
Keywords: intl
(Reporter)

Comment 3

15 years ago
Created attachment 148113 [details]
Additional XHTML Testcase

This bug is more serious than just a few glyphs. Mozilla refuses to display
lots of non-ASCII characters in TITUS Cyberbit Basic (and other fonts as well,
such as Arial Unicode MS) when the document explicitly specifies that font.
(Reporter)

Comment 4

15 years ago
Created attachment 148114 [details]
Screen capture of attachment 148113 [details] as shown by Mozilla-Mac/2004042110

It might be interesting for someone running 10.3.x to confirm this as well,
since I知 still back at 10.2.8.
(Reporter)

Comment 5

15 years ago
Note that Safari displays both testcases properly.
Summary: Some font glyphs are not being displayed under Mac OS X 10.2.6 → Some font glyphs are not being displayed under Mac OS X 10.2.x
(Reporter)

Comment 6

15 years ago
Works fine using Win/1.6, so pp.
Keywords: pp
(Reporter)

Comment 7

15 years ago
Still a problem using OS X 10.3.3.
Summary: Some font glyphs are not being displayed under Mac OS X 10.2.x → Some Unicode text is not displaying in the requested font face
*** Bug 244498 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

12 years ago
Appears fixed using Camino/2007010201 (1.2+), probably due to Cairo.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.