Table in e-mail body causes send of e-mail to fail

RESOLVED DUPLICATE of bug 224733

Status

MailNews Core
Composition
--
major
RESOLVED DUPLICATE of bug 224733
15 years ago
9 years ago

People

(Reporter: David Campbell, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529

I have a situation where a message won't send because of its content.

Reproducible: Always

Steps to Reproduce:
1.Save attached html and load into composer
2.Press CTRL-A in the composer window to highlight it all
3.Press CTRL-C to copy everything there
4.Create a new mail message
5.Press CTRL-A in the new mail message text area so as to highlight it all
6.Press CTRL-V to paste in the content from composer
7.Give the message an e-mail address and a subject
8.Press send

Actual Results:  
A window comes up saying:
Sending of message failed.
Please verify that your Mail & Newsgroups account settings are correct and try
again.

Expected Results:  
Sent the e-mail.

I suppose this could be because of some interaction with the SMTP server, but
other e-mails send just fine.

If you cut the table out, the message sends ok.
(Reporter)

Comment 1

15 years ago
Created attachment 124797 [details]
message content used for reproducing this problem
(Reporter)

Comment 2

15 years ago
Hmm,

It seems this stems from the fact that when you copy a message from your sent
messages folder into composer, composer can end up with mailbox: references in
the file, like this:

<img
src="mailbox:///C%7C/david/Mail/Sent?number=23453816&amp;part=1.1.2&amp;filename=show_details.gif"
 width="11" height="11" border="0"
 onmouseover="flipImage('segment5', true)"
 onmouseout="flipImage('segment5', false)">

If you chop them out, then the message sends.

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 224733 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.