On Win98 w/Vanta chipset, new windows refuse to refresh after short/extended usage

RESOLVED DUPLICATE of bug 204374

Status

--
critical
RESOLVED DUPLICATE of bug 204374
16 years ago
10 years ago

People

(Reporter: asilver76, Assigned: kmcclusk)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030507

The page given (www.oldversion.com) is simply na example page indicative of
nothing specific in and of itself. Any page with multiple links or graphic
images (i.e. yahoo/lycos groups) or complex rendering (i.e. most professionally
done webpages) will not render correctly after either short or extended usage
(veries) on WIndows98 with 8MB NVIDIA VANTA chipset. Effectively, after
rendering between 1-30 web pages, the browser will refuse to refresh either when
new windows or created, or when links in a given window are clicked. Resizing
the window restores the actual (new) content, but remaximizing results in image
corruption that clear when the scroll bar is utilized. Restarting of the browser
fixes this problem. Also, browser responsiveness drops immeadeately prior to
this bug manifesting itself (i.e. opening new windows suffer a speed decrase of
approx 25%-50% for one or two instances before the bug manifests itself.)
Updating VANTA drivers and/or Direct X version (8 - 9), has no effect on this
bug. Likewise, clearing both browser and system memory cache has no effect on
the bug. This bug first manifested itself in browser version 1.3, which leads me
to suspect that it has something to do with the implementation/integration of
the new "smooth scrolling" code.     

Reproducible: Always

Steps to Reproduce:
1.Load complex web pages or web forums
2.Repeat, Repeat, Repeat
3.Lack of window refresh/webpage corruption will eventually appear. 

Actual Results:  
The lackf of windows refresh/web page corruption appeared, taking being 5-30
minutes to manifest itself

Expected Results:  
The same as above. What the Mozilla team should do is check the current page
rendering codebase vs. 1.0 release and then systematicly review every
change/enhancement that might be interpreted as "chipset specific", and make
such enhancements configurable via the about:config panel, thus allowing
possibly inadvertantly conflicting optimizations to be turn off at the user
level (with the coresponding lack of features/speed, of course). 

The theme being used currently is Grey Modern, but the bug seems to manifest
itself equally well in both Modern and Classic. No actual crash of Mozilla
occurrs when this bug takes place, so error codes are not generated. Incidently,
in version 1.4b the "rollover madness" test in the XBL suite now crashes
Mozilla, but if this has anything to do with thie particular bug, then I am not
aware of it. 

My system configuration is as follows:
P-III 550
128 MB RAM
Vanta 8MB integrated graphics chipset
Windows 98SE
DirectX 8a (was 9, but was reinstalled when bug first appeared, on the
assumption that is was a DirectX problem)
Mozilla: 1.4b (bug also occurs in Mozilla 1.3 as well)

Comment 1

16 years ago
Reporter:
What are your Win9x resources like when you see this problem?  (use Resource
Monitor)
http://support.microsoft.com/?kbid=300059

Comment 2

15 years ago
I have this bug also, and am able to reproduce it regularly. I have been looking
at art websites of late (http://elfwood.lysator.liu.se/elfwood.html), and it
happens very often (as described in bug #208123).

After the refresh problem occurs, to clear up the problem, I simply close
Mozilla, and open it again, and then the window refreshes fine (for a while).
Also, when the refresh problem occurs, if I happen to have Internet Explorer
open at the same time, the IE window is also unable to refresh. When I close
and/or reopen Mozilla, the IE window is able to refresh again without having to
close and reopen IE. (It does not matter if IE is open or closed for this bug to
occur in Mozilla.) 

When the refresh problem occurs, my MS resource meter reads... System Resources:
48% free, User Resources: 68% free, and GDI: 48% free. Normally, the values are
70%, 70%, and 78% free. When I close Mozilla, it takes about a minute for the
resource meter to go back to the normal values. 

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624
Windows 98 SE 4.10 Build 2222
AMD Athlon 1200
512 RAM (DDR 2700)
Nvidia GeForce 4200 Ti (Asus 128MB card) 1280 x 960 optimal refresh rate
Video driver: (Detonator) nvdisp.drv 4.13.01.4109 (English) 11/18/02 14:15:00,
103424 bytes
DirectX 8.1 (4.08.01.0881)
Internet Explorer 6.0.2800.1106 128 bit encryption

I hope this info helps track down this bug. Let me know if any more info is needed. 
(Reporter)

Comment 3

15 years ago
New Information on this bug. I believe, after extended testing, that this bug is
do to a memory/system resource allocation error. In short, Mozilla, is not
flushing its memory/system cache effectively for some reason, resulting in an
eventual overflow and consequent browser window overwriting/corruption. Tracing
this problem back though the builds, this problem first becomes evident at the
Mozilla 1.2 branch, but for some reason escalated in severity in the 1.3/1.4
branch. By being unable to free up/reclaim system resouces, Mozilla will
continue  create these errors in all future builds. Please note that manually
clearing the memory cache does not solve this problem - only a full shut down
and restart of Mozilla does. 

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 204374 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.