tabbed browsing hogs memory ferociously

RESOLVED DUPLICATE of bug 204374

Status

defect
--
critical
RESOLVED DUPLICATE of bug 204374
16 years ago
11 years ago

People

(Reporter: theshuberts, Assigned: jag+mozilla)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529

Under Mo1.2/1.3, I was able to open about 50 tabs on my Win98SE machine with
384Mb of RAM (probably more, actually, I just never tried it).  On 1.4, I cannot
open 20 tabs.

Reproducible: Always

Steps to Reproduce:
1.  Go to, e.g., www.cnn.com
2.  Open a story link in a tab. 
3.  Repeat step 2.
4.  Number of simultaneous open tabs is significantly higher in previous
versions of Mozilla.

Actual Results:  
Got a "low resource box."

Expected Results:  
Used less RAM.

Closing open tabs only helped a little, and only for a little while. 
Ultimately, I had to shut down and restart Mozilla.  DID NOT have to reboot,
however.  But aside from horrendous memory hogging, there also seems to be a
problem with reclamation of memory associated with open tabs.

Comment 1

16 years ago
FWIW, Win9x resources are not the same as RAM.
A Win98 machine with 32MB ram has the same amount of resources as one with 2GB RAM.

I'm surprised you could get 50 tabs with previous versions under 9x.

*** This bug has been marked as a duplicate of 204374 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.