Closed Bug 208354 Opened 17 years ago Closed 13 years ago

blogspot.com - character entities improperly encoded

Categories

(Tech Evangelism Graveyard :: English US, defect, P4, minor)

x86
Windows 98

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: xavierbasora, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529

I go to the Spanish language site called http://www.analisiscatolico.blogspot.com/
The title and the preambule to this blog don't display the accented letters
properly. They show up as raw HTML code e&acute etc. However, interestingly
enough the actual posts, the accented letters are properly .
I contacted the the blog authour who tells me that teh browsers he uses at his
home and office display the title and preambule correctly. He didn't specify
what he uses for a browser.
I haven't checkked yet with Real's mini browser based on Internet Explorer
components.



Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
Display the title and prabumble accented chracters correctly
Entity references like &oacute always end in a semi-colon (ó).  They are
breaking on this page because none of them do.

->TE
Assignee: general → nitot
Severity: normal → minor
Status: UNCONFIRMED → NEW
Component: Browser-General → Europe: West
Ever confirmed: true
Priority: -- → P4
Product: Browser → Tech Evangelism
QA Contact: general → brantgurganus2001
Version: Trunk → unspecified
I don't read Spanish, so I've assigned this to Europe:West on the assumption
it's based in Spain.  Reassign to correct component if it's not.
Summary: The title and preambule to the blog's accented letters are improperly displayed → analisiscatolico.blogspot.com - character entities improperly encoded
Bill:
The blog isn't based in Spain but in the U.S.
I'm a bit confused what do you mean by none of them are breaking on the page?
xavier
Reassigning to US Gen per last comment.

I didn't say none of them are breaking.  None of the entities end in the
required semi-colon, so all of them are breaking.
Assignee: nitot → susiew
Component: Europe: West → US General
QA Contact: brantgurganus2001 → zach
Thanks for the clarification. I understand now.

xavier 
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us
Summary: analisiscatolico.blogspot.com - character entities improperly encoded → blogspot.com - character entities improperly encoded
*** Bug 235118 has been marked as a duplicate of this bug. ***
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1b1) Gecko/20060802 SeaMonkey/1.1a
WFM, site is encoded in UTF-8 now

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
  <title>Análisis Católico</title>

  <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.