If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Doesn't handle CGI script the same way IE does

RESOLVED DUPLICATE of bug 65827

Status

SeaMonkey
General
--
minor
RESOLVED DUPLICATE of bug 65827
15 years ago
4 years ago

People

(Reporter: Adam Skinner, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529

Unfortuantely this page is restricted, so you won't be able to log in.  It's
part of Wachovia's account download, we it uses a script to send you an .ofx
file (XML file MS Money uses to import account information).  When IE opens
this, it asks you to save or open filename.ofx (which has a WindowsXP file
association).  When Mozilla opens it, filename.ofx.cgi is given (same file, same
XML, no wrapper akaik).  If I save the file and delete the .cgi at the end, I am
them able to do my import.
That's a workaround though.  What we want is to be able to drop the .cgi during
this download process.

Reproducible: Always

Steps to Reproduce:
1. Click on the download link in Wachovia (a js just gives you the ofx file)
2. It has .cgi appended to it.


Actual Results:  
The .cgi file was given (not the actual file, but the normal .ofx file with a
.cgi extention appended to it)

Expected Results:  
Dropped the .cgi and given me simply filename.ofx

Comment 1

15 years ago
I'm a bit out of my depth here, but i can think of two possible causes.

1) the server is configured to serve it as cgi and adds it that way. In that
case it might be that IE [in conflict with standards!] overrides the file type
and determines it as .ofx whereas Mozilla does what the server tells it to.

2) you may have a wrong entry in your HELPER APPLICATIONS part of the NAVIGATOR
preferences. Check for entries with ofx or cgi.

Third possible cause is that indeed there IS something wrong ;)
The third possible cause is the extension-fixup code in Windows versions of
Mozilla.  Please find the relevant bug and mark this duplicate.
Whiteboard: DUPEME

Comment 3

15 years ago
see bug 65827 comment 60

*** This bug has been marked as a duplicate of 65827 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.