If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

background images on :hover do not preload + forced preloading with relative url's doesn't work

RESOLVED DUPLICATE of bug 57607

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 57607
15 years ago
15 years ago

People

(Reporter: Julius Geczy, Assigned: dbaron)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210

I have a CSS graphic rolover menu of anchors set to block mode with bg-images on
normal state and :hover pseudoclass. Used background images on :hover do not
preload! After the page loaded, the :hover bg image starts loading at the first
use of rolover - blank rectagle displayed temporarily.

I tried to preload them with JavaScript (relatively linked urls) - Moz didn'
identify images with the same relative url on the page with those in the CSS :hover.

Even preloading them with another block in CSS, using the same relative URL
didn't identify images as the same. Load on first use :(.

I managed to fix the CSS preloading by putting the absolute URLs into
background-image values. Now the identifying works, but makes the stylesheet
unportable :(

fixed version will be available after 6/6/2003 at the mentioned URL. Portability
issue solved by CSS stylesheet generated by PHP.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
This is probably a dup. We should be pre-loading all URLs mentioned in stylesheets.
Depends on: 113173
It's a known bug that we don't load background images until paint.

*** This bug has been marked as a duplicate of 57607 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
No longer depends on: 113173
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.