Closed Bug 20851 Opened 20 years ago Closed 17 years ago

Implement partial HTTP caching

Categories

(Core :: Networking: HTTP, defect, P3, minor)

defect

Tracking

()

VERIFIED WORKSFORME
Future

People

(Reporter: fur, Assigned: darin.moz)

References

Details

(Keywords: perf)

I don't think any API or implementation changes are necessary in the cache
manager to implement partial caching.  All of the work should be in modifying
the HTTP protocol handler.

The cache manager already tracks whether content is truncated, such status being
made available via nsICachedNetData::GetPartialFlag().  There is also a pair of
accessor methods for the allowPartial flag which controls the cache behavior
with respect to partially-filled cache entries.  The cache can also accommodate
non-zero file offsets when writing to the cache, i.e. so as to be able to append
content to an existing cache entry.

Sending the required byte-range headers in the HTTP request is trivial.  The
somewhat more difficult part will be "gluing" together the previously-cached
content with the newly arrived data from the server.
Blocks: 14050
Mass move of all bugs without target milestones to M13.
Bulk move of all Cache (to be deleted component) bugs to new Networking: Cache
component.
Assigning fur's cache bugs to Gordon. He can split them up with davidm.
Target Milestone: M13 → M15
Keywords: perf
Target Milestone: M15 → M17
Moving post beta bugs to M18 which is now the post-beta milestone.
Target Milestone: M17 → M18
*** Bug 26469 has been marked as a duplicate of this bug. ***
->future
Target Milestone: M18 → Future
This problem still exists on WinNT 2001041704.

The new cache has landed and been around for a while and seems to have become 
pretty stable.

A good example of what this bug will fix is:

1) Dial into the internet(yes people still do this in 3rd world contries)
2) Go look at an big image(not pr0n), something like a screen shot at themes.org
3) Before the image completely downloads, click <back>
4) Look at the image again

Result:
Image will start to download again.

Expected Result:
  Image will resume downloading
I've seen Netscape 4 successfully resume images and files.  This should probably
be marked 4xp...
Darin, do you have an interest in this?
Assignee: gordon → neeti
Component: Networking: Cache → Networking: HTTP
moving neeti's futured bugs for triaging.
Assignee: neeti → new-network-bugs
-> defaults
Assignee: new-network-bugs → darin
QA Contact: tever → httpqa
WORKSFORME .. actually a duplicate of a bug i fixed ages ago.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → WORKSFORME
Verified WFM.
Status: RESOLVED → VERIFIED
QA Contact: httpqa → junruh
You need to log in before you can comment on or make changes to this bug.