All users were logged out of Bugzilla on October 13th, 2018

P3P summary only works once

VERIFIED FIXED in mozilla1.4final

Status

()

--
major
VERIFIED FIXED
16 years ago
5 years ago

People

(Reporter: hjtoi-bugzilla, Assigned: harishd)

Tracking

({regression})

Trunk
mozilla1.4final
x86
Windows 2000
regression
Points:
---
Bug Flags:
blocking1.4 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed on the trunk], URL)

Attachments

(1 attachment)

Using an old profile, do:

1. Go to URL
2. View > Page Info > Privacy > Summary

Expected results: a summary view

Actual results: a dialog with message "Unable to display privacy summary for
http://www.att.com. Either the site does not have a privacy policy or it could
not be found"

Using a new profile works fine.
Target Milestone: --- → mozilla1.4final
Since bug 191920 was blocking1.4 and this is a regression caused by that (or if
you prefer, the patch doesn't actually fix p3p for old profiles), I'm going to
mark this one as blocking too.
Flags: blocking1.4+

Comment 2

16 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
Bug 191920 was only proposed to block 1.4final, it was not approved.
Flags: blocking1.4+ → blocking1.4?
bug 191920 was not only approved, it landed on the 1.4 branch already.
Flags: blocking1.4? → blocking1.4+
(Assignee)

Comment 5

16 years ago
In an attempt to find the problem I discovered one more BAD problem. The summary
window is populated only once. That's if you click on the summary button the
second time you will get an error message followed by a blank window. This is
very bad and IMO must be fixed for 1.4
Probably needs a xsltp.reset() right before line 62 (xsltp.setParameter("",
"policyUri", policyuri.spec);)
Comment on attachment 125423 [details] [diff] [review]
v1

This fixes the problem with viewing the summary more than once. The change in
Transformiix is needed because otherwise the xsltp.reset() call crashes.
Attachment #125423 - Flags: superreview?(heikki)
Attachment #125423 - Flags: review?(harishd)
(Assignee)

Comment 9

16 years ago
Comment on attachment 125423 [details] [diff] [review]
v1

r=harishd
Attachment #125423 - Flags: review?(harishd) → review+
Comment on attachment 125423 [details] [diff] [review]
v1

I notice this fixes the comment issue as well, thanks.
Attachment #125423 - Flags: superreview?(heikki)
Attachment #125423 - Flags: superreview+
Attachment #125423 - Flags: review?(harishd)
Attachment #125423 - Flags: review+
Samir, we noticed that this was actually more serious than first thought, so
nominating this again.
Keywords: nsbeta1- → nsbeta1
Summary: P3P summary does not work with old profiles → P3P summary only works once
Comment on attachment 125423 [details] [diff] [review]
v1

Doh, I wiped out harishd's review, adding it back.

Drivers, this is a low risk fix for 1.4final blocker, requesting approval to
land on 1.4 branch.
Attachment #125423 - Flags: review?(harishd)
Attachment #125423 - Flags: review+
Attachment #125423 - Flags: approval1.4?
(Assignee)

Comment 13

16 years ago
Fix checked in on the trunk.
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Whiteboard: [fixed on the trunk]

Comment 14

16 years ago
Comment on attachment 125423 [details] [diff] [review]
v1

a=asa (on behalf of drivers)for checkin to the 1.4 branch.
Attachment #125423 - Flags: approval1.4? → approval1.4+
Sent request for ADT approval.
Reserved ADT approval from Rafael and Marina. Ok to land on 1.4 branch.
a=adt Please add fixed1.4 keyword after landing on branch

Comment 18

16 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
Checked in on branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Keywords: fixed1.4
Resolution: --- → FIXED

Comment 20

16 years ago
updating qa contact to gbush@netscape.com
QA Contact: ashishbhatt → gbush

Comment 21

16 years ago
branch build 20030617
Keywords: fixed1.4 → verified1.4

Comment 22

15 years ago
verified build 2003120808
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.