Windows User Password shown by JavaScript

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: Christian, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

In the page at
http://www.kontakt69.de/96743/56987/86357/36789/randoben_black.html is a
JavaScript which should open an InputDialog to ask for a Name. This Dialog isn't
opening. instead of the missing username the Windows User Password is shown.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Christian, this is WFM on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.4b) Gecko/20030607 Mozilla Firebird/0.6

There are some weird javascript issues associated with the 05/16 0.6 milestone.
 Would it be possible to update to a current or recent nightly build to retest this?

Comment 2

15 years ago
This works for me using Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4b)
Gecko/20030609 Mozilla Firebird/0.6

Christian, please download latest nightly build as suggested by Mike using 
http://komodo.mozilla.org/pub/firebird/nightly/latest-trunk/MozillaFirebird-win32.zip,
extract archive in a *new* directory and create a new profile by calling
MozillaFirebird with option "-p" - this should resolve your problem.
I will also try again using a XP box today just to make sure it's not an XP issue.
We've had this problem long, long ago and it has regressed at least once that I
know of--I don't want to just dismiss it. But unless we can figure out why it's
happening to you and not to anyone else there's not much we can do.

If this is like the previous cases it's not necessarily your windows password,
it's the password for whatever site is first in your password list. You can look
in your prefs for a .s file and check to see what host is on top.

Do you access the example page using a different URL, perhaps on an internal
network?

When you say the dialog isn't opening, then where is the windows password
showing up? In the old bug I'm thinking of the prompt definitely did open, but
was prefilled with the password.

Comment 4

15 years ago
This WFM on the latest nightly, the dialog opens, and the page shows whatever I
put inside it.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030702 Mozilla
Firebird/0.6

I've also tried reproducing it on the .6 milestone, with no results. This might
have been an issue caused by a specific theme or extension. (Using classic FB
theme and no extensions, for my part.)

Comment 5

15 years ago
Christian, since there was no response from your side to the questions made in
this bug I'll resolve this one as "works for me".

If problem still persists on your side _after_ downloading latest nightly build
and creating a new profile by calling MozillaFirebird.exe with option "-p"
please feel free to reopen this bug and to provide the new information!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.