win95/win98/winme resource usage is extremely high

RESOLVED DUPLICATE of bug 204374

Status

defect
--
critical
RESOLVED DUPLICATE of bug 204374
16 years ago
15 years ago

People

(Reporter: kheprifu, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529

On Windows 98 and other such 'Win9x' systems, Mozilla consumes a vast amount of the 16-bit resources available, leaving other running applications with little to no USER or GDI resources available, which causes malfunctions in many other programs, it also generally prevents the user from running more than one or two applications in concurrence. This also applies to the system tray fast-start icon which loads Mozilla into memory, it exhibits the same behavior and causes the same problems. Internet Explorer does not have this problem, nor do most apps.

Reproducible: Always

Steps to Reproduce:
1. Start a program to monitor system resources
2. Start Mozilla
3. Watch available USER/GDI resources plummet.
4. Start other applications.

Actual Results:  
Other apps start to quickly malfunction and/or crash, and not many can be loaded at once (because of the 16-bit resource problem on all versions of Win9x).

Expected Results:  
It should be coded to only take an extremely minimal amount of USER/GDI resources when running on a per-window basis, as to not interfere with other applications, and it can run more than a handful of Mozilla windows at the same time as well.

This won't occur on anything Windows NT based, such as NT4, Win2K, or WinXP, but it's rather severe on Windows 98, and I would guess it may cause some kind of non-obvious problems on the NT-based systems as well if it's using such an incredible amount of resources (an average of 85% of GDI resources and 70% of USER resources on my system).

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 204374 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.