Networking is broken after long idling

RESOLVED WORKSFORME

Status

()

Core
Networking
--
major
RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: Max Alekseyev, Assigned: mkaply)

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
OS/2 build 2003060209

I often leave Mozilla running in background for a day.
But next day it's unable to connect any site or POP3 server. So I'm forced to
restart it to make it worked.

To reproduce:
1. Run Mozilla Navigator
2. Ensure it works fine
3. Leave it running in background for a day
4. Try to connect any site

Comment 1

15 years ago
WFM. I often leave it running 3 or 4 days. Using vacpp 2003060712 at the moment.
(Reporter)

Comment 2

15 years ago
I've just got the problem with 2003060809 build.

No errors were produced. The sites were simply being loaded forever, and
throbber was throbbing and throbbing...
I've tried to enter http://localhost in a new tab: result is the same with
status line stuck at "Resolving host localhost..."
Probably, host resolving was dead in Mozilla. Other internet applications
including "host" command worked fine.

Comment 3

15 years ago
max: whenever mozilla gets into this state, you might try toggling the
online/offline button to see if that has any effect.

-> mkaply since this bug is for OS/2
Assignee: darin → mkaply
(Reporter)

Comment 4

15 years ago
Yeah, indeed switching to Offline and then back to Online resolves the problem.
(Assignee)

Comment 5

15 years ago
Darin, has this ever been seen in the past on other platforms?
(Reporter)

Comment 6

15 years ago
But I cannot get Mail back to life. Mozilla doesn't connect to mail servers
(silently, with no errors of any kind). Trick with going offline/online doesn't
help.
But at the same time news-servers work fine.
(Reporter)

Comment 7

15 years ago
MailNews part of the problem seems to be bug 173924.
Depends on: 173924

Comment 8

15 years ago
I have seen this, too, but not yet with 1.4 RC1 or 1.4 RC2. I'm using the 4.3.2
IP stack (I can dig out the details if need be), though other IP connectivity
seems unaffected. Offline/online toggle helps sometimes, other times I am forced
to kill the process (exiting doesn't shut it down completely, which may be the
real bug) and restart Moz.

I haven't seen this on other platforms.
(Reporter)

Comment 9

15 years ago
I'm using latest TCP/IP as well. Precisely speaking:

Version numbers of TCP/IP protocol drivers:
   SOCKETS.SYS: 6.3100
   AFOS2.SYS:   6.3100
   AFINET.SYS:  6.3100
(Assignee)

Comment 10

14 years ago
Do you still see this problem?
(Reporter)

Comment 11

14 years ago
The bug seems to have gone in recent builds. But while testing for this one,
I've got another illustration of bug 195960.

Marking as WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

12 years ago
No longer depends on: 173924
You need to log in before you can comment on or make changes to this bug.