Unexpected handling of SELECT/OPTION Javascript interface

VERIFIED DUPLICATE of bug 16879

Status

()

Core
DOM: Core & HTML
P3
major
VERIFIED DUPLICATE of bug 16879
19 years ago
19 years ago

People

(Reporter: pawsa, Assigned: Eric Pollmann)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Look at the given URL and note following:

1. Field subsection does not respond to user actions.

2. Field subsubsection has no options at all under Netscape (expected behavior)

but Mozilla's javascript does not remove the initial value.

Updated

19 years ago
Summary: Unexpected handling of SELECT/OPTION Javascript interface → [wip+rods]Unexpected handling of SELECT/OPTION Javascript interface

Comment 1

19 years ago
I will take a look at this tomorrow

Comment 2

19 years ago
In an attempt to get my bug list in order again, marking all the bugs I have
currently as ASSIGNED.
(Reporter)

Comment 3

19 years ago
I have prepared another, slightly simpler test for you:
http://www.theochem.kth.se/~pawsa/mozilla1.html
It seems that options array of the select object is not treated as an ordinary
array i.e. one cannot truncate it by assigning a value to options.length.
setting array elements to null seems to remove them but I would not call it
as a pretty solution.

Updated

19 years ago
Summary: [wip+rods]Unexpected handling of SELECT/OPTION Javascript interface → Unexpected handling of SELECT/OPTION Javascript interface

Comment 4

19 years ago
Removing wip+rods, I can't help with this, I can't figure out where the array
element is getting set to null.
(Reporter)

Comment 5

19 years ago
I hope this is not some kind of misunderstanding: the example with setting the
elements to null was on
http://www.theochem.kth.se/~pawsa/mozilla1.html
Note the number `1' in the file name.

Updated

19 years ago
Blocks: 22176
(Reporter)

Comment 6

19 years ago
Created attachment 4097 [details]
The shortest sensible test case I could find.
(Reporter)

Updated

19 years ago
Whiteboard: [TESTCASE]
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase

Comment 8

19 years ago
Sorry for the runaround on this one. Passing along to Pollmann, since he has the 
bulk of SELECT/OPTION issues on his list.
Assignee: vidur → pollmann
Status: ASSIGNED → NEW
(Assignee)

Comment 9

19 years ago
This is already reported as bug 16879.  Marking as a duplicate.  Thanks!

*** This bug has been marked as a duplicate of 16879 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 10

19 years ago
Dup, verified.
Status: RESOLVED → VERIFIED

Updated

18 years ago
No longer blocks: 22176
You need to log in before you can comment on or make changes to this bug.