All images disappear, including toolbar graphics

VERIFIED DUPLICATE of bug 204374

Status

()

defect
--
major
VERIFIED DUPLICATE of bug 204374
16 years ago
16 years ago

People

(Reporter: brianwcarver, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030608 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030608 Mozilla Firebird/0.6

On both .6 and the June 8th nightly build after using the browser for a while
images start disappearing on all sites. The toolbar graphics, like the back and
reload buttons, disappear too once you pass the mouse over them once. Once this
starts it seems that it only takes a couple page loads to be totally imageless.
I typically restart once this begins though, and the problem is gone after
restart (but only for a while!)

Reproducible: Always

Steps to Reproduce:
1. Start Firebird on Windows 98.
2. Browse the web.
3. Images start disappearing after a while, including the toolbar graphics.

Actual Results:  
Lost all images.

Expected Results:  
Displayed images.

Comment 1

16 years ago
Brian, this is WFM using Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4b)
Gecko/20030609 Mozilla Firebird/0.6

Is this a installation into a _new_ directory together with a fresh profile? If
any of these questions has been answered with "no" or "I don't know" then please
download latest nightly build and extract the archive into a _new_ directory and
create a new, additional profile. You can create an additional profile (without
losing your old profile) by calling MozillaFirebird with option "-p" then
"Manage profiles" -> "Create new profile".

It's also necessary to know wthether you currently use themes besides the
standard theme and / or extensions when you encounter this problem.

Additionally it would be helpful to know the rough time ranges after this one
happens - are we talking about minutes or half an hour / hours?

Comment 2

16 years ago
It works for me to on Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b)
Gecko/20030608 Mozilla Firebird/0.6

But I can remember having this problem some time ago when my Win98 ran out of
ressources for bitmaps, because another Problem used a lot of icons, etc. 

Comment 3

16 years ago
Well, I can give it a try on my girl-friends laptop running Win98SE this
evening, but since she uses Moz.Firebird very often and long it would be
interesting to know the %-number of free (GDI?) resources when this occurs to
have something to compare with.

Comment 4

16 years ago
Possibly related / dupe of bug #204374, where also problems with the UI are
mentioned when GDI resources are low... 
Additionally I found bug #199443 which has GDI usage monitor attached. Using
this one we might be able to proof that problem is really related to low resources.
This machine has been using Firebird/win98 for a month now, have not been able
to replicate this.  Either this is a dupe of bug 204374 or its worksforme
especially with the lack of response for one month.

Reporter, the tool at the link below can be used to track GDI usage.  If you're
still interested, try using it to see if GDI usage is the culprit.  If so, wait
on the fix for 204374 to land and that will fix the next firebird build.

http://bugzilla.mozilla.org/attachment.cgi?id=121792&action=view
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

16 years ago
Hi, this is the original reporter of the disappearing toolbar graphics problem.
 I was moving and lost internet access. Sorry.

I have just duplicated the bug. I installed Win98SE on a cleanly formatted
harddrive and installed nothing but the Ethernet card drivers and sound drivers,
7-zip a free-software unzipping program, and MozillaFirebird 0.6. I installed
into C:/Program Files/Mozilla/MozillaFirebird. (At this point I didn't notice
the bug, but only used Firebird briefly.) Now after installing Adobe, Java,
QuickTime, Realplayer, Flash, and Shockwave I get the bug again. It usually does
take more in the range of a half hour of use to get the problem, but it makes
the browser unusable very quickly. I should add that the font changes, even for
dialog boxes, when the bug appears. It is temporarily resolved by closing the
browser and restarting it. I use the classic (default) theme and in fact have
never gotten the Modern theme to work with Firebird. (Different or related bug?
I dunno.)

I will try to be more responsive this time. I also need (and thank you for) very
explicit instructions. For instance "create a new profile" is not as good as "Go
to directory X, delete files W, Y and Z, and then restart mozilla with a command
line of mozillafirebird.exe -p" That sort of detail is what I need. I have begun
using the GDI usage tracker, but have no idea what it is or what to do with it.
I'll report anything from it that I think relevant or am asked for. Thanks!
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 7

16 years ago
I've been using the GDI Usage Tracker and can report that the Bitmap number at
the top gets quite large when the problem is occurring. (In the range of
700-1100) whereas during normal usage it is often around 140. Some of the other
numbers get larger but the top one sees the most remarkable jump.

Also, when this is happening, until I close Firebird it even screws up the fonts
and images of any other regular Windows function. Like clicking on the Start
button and then scrolling over options makes them disappear, and any regular
Windows Dialog box gets an unreadable font.

Hope this helps. Let me know what else I can check for you.

Comment 8

16 years ago
I've been encountering this bug as well... but it vanished after I updated to a
more recent nightly. Probably better GDI handling helped delay it a bit, but the
bug could surface again. 

This sounds like a duplicate of bug 204374 to me as well... :)

If I'm right the symptoms are suddenly vanishing toolbar widgets, followed by
messy fonts and such in the browser as well as windows. And nothing short of a
total reboot seems to solve it?

Comment 9

16 years ago
*** Bug 209459 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
I read through bug 204374 more carefully it covers this perfectly... so many
comments, it's easy to get lost. :P

*** This bug has been marked as a duplicate of 204374 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.