marquee stops if JS is turned off

RESOLVED WORKSFORME

Status

()

Core
Layout
--
minor
RESOLVED WORKSFORME
14 years ago
3 years ago

People

(Reporter: Galileo Vidoni, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2) Gecko/20021120 Netscape/7.01
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2) Gecko/20021120 Netscape/7.01

If you are navigating a pege with marquees, and you turn JS off, the marquees
stop scrolling.

Reproducible: Always

Steps to Reproduce:
1.Enter to a site with marquees
2.Turn off JavaScipt in Advanced-->Scripts & Plugins
3.Look again at the marquees :-P

Actual Results:  
the marquees stopped scrolling, and they remain like that until I reload (and
not "refresh", that **** M$...!!) the page.

Expected Results:  
The marquees should have continued scrolling
.
Assignee: roc+moz → doron
Component: Layout: View Rendering → Layout

Comment 2

14 years ago
marquee is xbl, so if xbl is affected by js being turned off, I can't do much
about it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
jst, do we listen for changes to that pref and halt scripts?  If so, where does
that code live?

Comment 4

14 years ago
related: bug 159932 disabling javascript in browser doesn't allow chrome:// to
add eventListners to window
glazou, is there a bug for your issues with XBL?  If so, please mark this
dependent... if not, file one?
Depends on: 236839
Duplicate of this bug: 456478

Updated

9 years ago
Assignee: doronr → nobody
OS: Windows XP → All
QA Contact: ian → layout
Hardware: PC → All
Depends on: 821850
No longer depends on: 821850
Depends on: 834697
Looks like this has already been fixed.

Boris, do you know about the kind of this bug?

# I confirmed on http://www.plusmb.jp/2012/10/12/5895.html (written in Japanese, though).
Flags: needinfo?(bzbarsky)
fixed by bug 834697?
That and or bug 944407.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(bzbarsky)
Resolution: --- → WORKSFORME
Duplicate of this bug: 159932
You need to log in before you can comment on or make changes to this bug.