Mozilla accessed over VNC is crashing when invoking the flash-plugin

RESOLVED DUPLICATE of bug 285356

Status

External Software Affecting Firefox
Flash (Adobe)
--
critical
RESOLVED DUPLICATE of bug 285356
15 years ago
2 years ago

People

(Reporter: khoelzer, Assigned: Peter Lubczynski)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030425

When running Mozilla (tested with 1.3.1 or 0.94) over a VNC "link"
standard html-code works fine too -- only opening a site with needs the
flash-lib ("plugin") Mozilla crashes ungracefully.
The plugin works fine when evoked locally (i.e. direct X-access and no VNC)


Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
s.a.
Which Flash Plugin do you use (see help/about:plugins) ?

(Reporter)

Comment 2

15 years ago
used Plugin:  Macromedia Flash Player 6 for Linux  (Shockwave Flash 6.0 r79)

Comment 3

15 years ago
can you post Talkback ID for this crash
"mozilla/bin/components/talkback/talkback" or post a stacktrace via GDB (given
you built a debug build) ?
Severity: normal → critical
Keywords: crash, stackwanted
(Reporter)

Comment 4

15 years ago
I forced 2 crashes (to different target-URLs !) 
talkback IDs  TB20919505W and TB20919461H
Whiteboard: TB20919461H

Comment 5

15 years ago
Created attachment 127356 [details] [diff] [review]
Stack for Flash crash
This is either invalid or Tech evangelism 
(The flash player itself crashed)
Keywords: stackwanted
Whiteboard: TB20919461H
(Reporter)

Comment 7

15 years ago
I forgot to admit that the target machine is running two proc (SMP) ;-)
Is possible that the flashplayer or mozilla has thread-synchronisation problems ???
(and the lesser load of VNC (compared to a real Xserver) shows this this way)

Comment 8

14 years ago
Meant to say:

Macromedia
Flash Player 5
Netscape Plug-in for Linux
9 September 2002

Comment 9

14 years ago
craig, do you have the issue with Flash 6 ? Flash 5 is known to crash over VNC
afaik.

Comment 10

14 years ago
For what is worth, I can confirm the bug happens on:
Mozilla 1.4a

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401
    File name: libflashplayer.so
    Shockwave Flash 6.0 r79


It is very anoying.

Comment 11

14 years ago
previous topcrasher: bug 58937 (supposed to be fixed with Flash 6 on Linux).
related: bug 197202 ?

Comment 12

14 years ago
*** Bug 219116 has been marked as a duplicate of this bug. ***

Comment 13

13 years ago
Here's my experience:

RedHat 7.3, Mozilla 1.7, Flash Player 6.0, r79
RedHat 7.3, Mozilla 1.7, Flash Player 7.0, r25
Suse 8.2, Mozilla 1.2  Suse 8.2. Flash Player 6.0, r79
*Using RealVNC 3.3.6:
Any page with Flash content crashes the browser. For example: www.macromedia.com
Here's the message I get:
Gtk warning **: invalid cast from 'GtkSuperWin' to 'GtkWidget'
Gtk warning **: invalid cast from 'GtkSuperWin' to 'GtkWidget'
./run-mozilla.sh: line 72: 10030 Segmentation fault   "$prog" $[1+"$@"]

*Not using VNC (starting Mozilla via an X-Term window on my Windows laptop or on
another Linux desktop):
	Normal Behavior

RedHat 7.1, Mozilla 1.1, Flash Player 6.0, r79
*Using RealVNC 3.3.6:
Normal behavior.
*Not using VNC (starting Mozilla via an X-Term window on my Windows laptop):
Normal behavior.

*Another note, when I open the page that has the flash content, but the content
is not visible, the page loads. As soon as the content becomes visible, it crashes.

WORKAROUND:
After some research, I figured out that the problem was with the bit depth that
VNC was using. Apparently using 8-bits with RealVNC causes Mozilla to crash when
viewing Flash content. Increasing the bit depth to 16 solved the problem.

start a VNC server as follows:

vncserver -depth 16

Comment 14

13 years ago
Steve, can you post a Talkback ID for these crashes ?
Blocks: 211213

Comment 15

13 years ago
Done.(In reply to comment #14)


Comment 16

13 years ago
dupe of "mozilla crashes on SEGV loading site with Flash, when run in X-VNC,
8bit [@ PlatformBitBuffer::CreateScreenBits]"

*** This bug has been marked as a duplicate of 285356 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

8 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: bmartin → adobe-flash
Target Milestone: --- → 2004
Version: Trunk → 6.x

Comment 17

2 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Target Milestone: 2004 → ---
Version: 6.x → unspecified
You need to log in before you can comment on or make changes to this bug.