Viewing "Sent" folder should have a "TO" field instead of "From" field

VERIFIED DUPLICATE of bug 168060

Status

--
enhancement
VERIFIED DUPLICATE of bug 168060
16 years ago
14 years ago

People

(Reporter: gbogh42, Assigned: sspitzer)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

When viewing the Sent folder, only "From" addresses are displayed -- which is
completely useles in this context.  I already know that I sent all the messages
in my Sent folder!  There is no option to select to view who the emails were
sent TO.  Viewing the "Sent" folder in Evolution vs Mozilla mail is a good
example of the usefulness of this.

Also, for the same reasons, it's quite pointless to have a search feature that
searches for Sender in the Sent folder...

Reproducible: Always

Steps to Reproduce:
1.View "Sent" folder
2.
3.

Actual Results:  
Mozilla displays messages filed under "Subject", "Sender", etc

Expected Results:  
Displaying "sender" in the Sent mail folder is quite useless...  Instead, there
should be a "To" field that displays who the emails were sent to.

Compare with Evolution for a much more useful model.

Comment 1

16 years ago
Worksforme in build 2003061008 on Mac OS X 10.2.6. The 'Local Folders/Sent'
folder has a *recipient* field, not a *sender* like the other. Compare this with
the Trash folder for instance.

The 'Sent' folder on my IMAP-server doesn't have such a recipient-field though :
bug 168060. Reporter, is your Sent-folder stored on an IMAP-server ?

Comment 2

16 years ago
WFM, and I'm using IMAP. I see "recipient" in place of the normal "sender",
which is what I expect. If this is on an Imap server, then it is a dupe of
168060, as comment #1 suggested.

(Reporter)

Comment 3

16 years ago
Yeah, this is the same as bug 168060.  I am using a Courier IMAP server.  Sorry
for the dupe report, I tried a number of searches in the database but didn't
turn up 168060 previously.

There really needs to be a 'Recipient' or 'To' column in the column table.

*** This bug has been marked as a duplicate of 168060 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
verifying.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.