dragging a link onto an existing TAB opens a new TAB instead of updating the dropped-on one

RESOLVED DUPLICATE of bug 209008

Status

SeaMonkey
Tabbed Browser
RESOLVED DUPLICATE of bug 209008
15 years ago
10 years ago

People

(Reporter: rob larson, Assigned: jag (Peter Annema))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030529

when: with 1.4b and earlier
situation: a browser window is open with two or three TABs.  The content of
current TAB shows one or more links to other pages.
action:  click on a link and drag it up to one of the non-highlighted TABs
should do: it should bring the dropped-on TAB to the front and load it from the
dropped link
does: opens a new TAB and makes it current, leaving the dropped-on TAB's
condition unchanged.

Reproducible: Always

Steps to Reproduce:
1.open a browser window and create one or two additional TABs.  
2.access a page from the left-hand (probably doesn't matter) TAB which has one
or more links in it
3.drag and drop a link onto one of the non-current TABs.

Actual Results:  
It opened a new, additional TAB, made it current, and opened the link in it. 
I.e., it acted as if Open Link in New Tab had been picked from the popup menu.

Expected Results:  
The behavior in prior versions was to make the (existing) dropped-on TAB current
and open the link in it.

The workaround is to manage the proliferation of TABs by closing some from time
to time, but, in addition to being an extra hassle, the recent history (as
accessed via the Back button) is lost.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 209008 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.